RHEL 7.6 Workstation KDE Console Session Locked Up with No Password Prompt

Latest response

We have some applications that require to run at the RHEL 7.6 Workstation console using a dedicated non-privileged user account. After sometime of no manual activities (while processing are still going on in the background), the console session will get locked up. When that happens, hitting any key on the console will usually displays a password prompt to allow the session to be continued.

But we have experienced on a few occasions (and on different RLEH workstations too) that no password prompt will appear. The console screen will show a digital clock that updates itself every minute.

The top right corner will display the network, sound and power icons. Selecting any of them will return a small window showing the Sound bar , a greyed-out Ethernet Ethernet connection, and a pause (two small vertical bars) icon.

If we select the Pause option, the console screen will go black and it will pause the entire system.

There does not seem to be any option to resume the user application session as no password prompt appears.

I have tried masking the suspend and hibernate targets:
[root@gerbops3 ~]# systemctl list-unit-files | grep masked
hibernate.target masked
suspend.target masked

Unfortunately that did not help.

Does anyone have any idea what has gone wrong?

I have attached a photo to show the console display.

Many thanks in advance.

Peter

Responses

As there has been no response, I have tried the suggestion https://bugzilla.redhat.com/show_bug.cgi?id=1112982#c38

and did systemctl stop gdm.service systemctl start gdm.service

The console now reverts back to normal username prompt. But by entering the same user account and password, all we got is a clean login session.

All the work on the previous session have all gone. This is quite undesirable.

Anyone has a better idea how to resolve this as it has happened on at least 4 RHEL 7.6 workstations.

Many thanks.

Hi Peter,

Did you know that the KDE desktop environment has been deprecated on RHEL 8 and coming versions of RHEL 7 ?
My recommendation would be to remove this (in the future) not supported environment and use the default one ! :)

Regards,
Christian

Hello Christian,

No I don't. I believe I chose to install KDE Plasma as requested by our users.

Which is the latest recommended desktop?

Peter

Hi Peter,

The default and recommended DE on RHEL is GNOME, developed and fully supported by Red Hat. :)

Regards,
Christian

Thanks, Christian,

I shall discuss this issue with the users, as they have quite a fair amount of windows based applications that runs on the console. It will probably take some time to switch.

So back to this issue, not sure if anyone has some thoughts on trouble-shooting this. I have looked into ~/.kde, system messages, but found no error recorded.

Peter,

I am a KDE user, but I have not seen this issue. My first thought would be to have a look at the Screen Locker. (System Settings, Hardware, Display and Monitor, Screen Locker.) Mine is set to a Simple Locker rather than a screen saver, but I also have direct monitor access rather than remote access. While it might not be an answer, that may be a place to look.

Frank

Thanks, Frank.

I need to make a correction here. I have just checked with the users, and got corrected that the problem actually happened under GNOME environment. I am sorry that I got myself confused when I found some cache-,socket-, tmp- softlinks under the user's .kde folder pointing to invalid folders under /var/tmp/.

Any idea why the password prompt does not appear when the session is locked under GNOME?