Version of Springboot in Fuse 7.2 and 7.3

Latest response

Hi Friends,
Could you help me to know the exact version of Springboot framework used or supported in JBOSS FUSE 7.2 and 7.3 ( Springboot way of depoyment and packaging using Bill Of Material (BOM ) in POM ).

  1. Will JBoss 7.2 or 7.3 support Spring Boot 2.1.3.RELEASE?
  2. How can we check which are all the supported versions in JBOss repository?
    When we checked the repository, it seems it only contains the cryptographic hashes of the POM files,
    but could not find the versions of the artifacts (like Maven repository).

Responses

Hello,

Fuse 7.2 and 7.3 still support Spring Boot 1.5 only. Fuse 7.4 will add support for Spring Boot 2.x Please see https://access.redhat.com/documentation/en-us/red_hat_fuse/7.3/html/migration_guide/migrate_maven_projects#building-generate-bom for more details.

Hope that helps, Torsten Mielke

Regarding your question

"2. How can we check which are all the supported versions in JBOss repository?"

Its best to check the BOM and the dependencies it pulls in. See here for the various BOMs to use in Fuse 7.