Issue installing Puppet

Latest response

Hi,

I'm doing the Red Hat Satellite 6 Implementation course and now I'm trying to install Puppet for a client. The output of the client is the shown below. How can I fix it? Should I show you more files to solve the problem?

Thanks

Ivan Gonzalez

[root@satclient ~]# yum install puppet
Loaded plugins: enabled_repos_upload, langpacks, package_upload, product-id,
: search-disabled-repos, subscription-manager
rhel-7-server-rpms | 2.0 kB 00:00
rhel-7-server-satellite-tools-6.2-rpms | 2.1 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.8.6-2.el7sat will be installed
--> Processing Dependency: ruby(selinux) for package: puppet-3.8.6-2.el7sat.noarch
--> Running transaction check
---> Package libselinux-ruby.x86_64 0:2.5-6.el7 will be installed
--> Processing Dependency: libselinux(x86-64) = 2.5-6.el7 for package: libselinux-ruby-2.5-6.el7.x86_64
--> Finished Dependency Resolution
Error: Package: libselinux-ruby-2.5-6.el7.x86_64 (rhel-7-server-rpms)
Requires: libselinux(x86-64) = 2.5-6.el7
Installed: libselinux-2.5-14.1.el7.x86_64 (@rhel-7-server-rpms)
libselinux(x86-64) = 2.5-14.1.el7
Available: libselinux-2.2.2-6.el7.x86_64 (rhel-7-server-rpms)
libselinux(x86-64) = 2.2.2-6.el7
Available: libselinux-2.5-6.el7.x86_64 (rhel-7-server-rpms)
libselinux(x86-64) = 2.5-6.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report
Loaded plugins: langpacks, product-id

Responses

Hi Ivan,

From the following error message:

Error: Package: libselinux-ruby-2.5-6.el7.x86_64 (rhel-7-server-rpms)
Requires: libselinux(x86-64) = 2.5-6.el7
Installed: libselinux-2.5-14.1.el7.x86_64 (@rhel-7-server-rpms)

It is understood that your system has got "libselinux-2.5-14.1.el7.x86_64" installed which looks to the latest one, however, puppet wants a lower version of "libselinux-ruby" which is dependent on "libselinux", hence, the error. You may try to install "libselinux-ruby" first and then install 'puppet', check if that helps. In case error again showing discrepancies between versions, you may better run an update on the system which would make it loaded with latest patches and updates. Once done, then try to install 'puppet' and check if that works. Also, you may wish to try with Satellite 6.3 instead of 6.2

Hi all, I have the very same error too with RHEL 7.6. (3.10.0-957.el7.x86_64 #1 SMP, x86_64 x86_64 x86_64 GNU/Linux)

yum -y install puppet

.......................

..................

........

--> Processing Dependency: libselinux(x86-64) = 2.5-12.el7 for package: libselinux-ruby-2.5-12.el7.x86_64

--> Finished Dependency Resolution

Error: Package: libselinux-ruby-2.5-12.el7.x86_64 (rhel-7-server-rpms)

       Requires: libselinux(x86-64) = 2.5-12.el7

       Installed: libselinux-2.5-14.1.el7.x86_64 (@anaconda/7.6)

Problem here is that libselinux-ruby is already installed, I tried also to reinstall

[root@mysrv ~]# yum -y install libselinux-ruby --skip-broken

Loaded plugins: product-id, search-disabled-repos, subscription-manager This system is not registered with an entitlement server. You can use subscription-manager to register. Resolving Dependencies --> Running transaction check ---> Package libselinux-ruby.x86_64 0:2.5-12.el7 will be installed --> Processing Dependency: libselinux(x86-64) = 2.5-12.el7 for package: libselinux-ruby-2.5-12.el7.x86_64

Packages skipped because of dependency problems: libselinux-ruby-2.5-12.el7.x86_64 from rhel-7-server-rpms

Hi Nenad,

It looks to me that your system is not properly synced or updated with package repository. Also, make sure your system is subscribed as I could see there is an error when you run yum command:

This system is not registered with an entitlement server. You can use subscription-manager to register

Please run 'yum clean all' and then try installing 'libselinux-ruby' package which should pull out the latest one from repo.

I was able to get it working on my RHEL7.6 test system in installing 'libselinux-ruby-2.5-14.1.el7.x86_64':

[root@rhel7 ~]# yum install libselinux-ruby
Loaded plugins: product-id, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package libselinux-ruby.x86_64 0:2.5-14.1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================
 Package                              Arch                        Version                              Repository                               Size
=====================================================================================================================================================
Installing:
 libselinux-ruby                      x86_64                      2.5-14.1.el7                         rhel-7-server-rpms                      121 k

Transaction Summary
=====================================================================================================================================================
Install  1 Package

Total download size: 121 k
Installed size: 169 k
Is this ok [y/d/N]:

All the best!