Header V3 RSA/SHA256 Signature Key ID FD431D51:BAD

Latest response

So I followed the three steps to fix this but I ended up deleting both files, but I have a back up of the two files how do I replace the file so I can run it again reboot and fix the file? First step I did was to run the command rpm2cpio nss-softokn-freebl-3.14.3-23.3.el6_8.x86_65.rpm then change the cd to /usr/ and copy the file there but when I restart is states it is new and was updated but then when I run the rpm -qa command I get the same error on all my rpm packages error: rpmdbnextIterator: Skipping H# ### Header V3 RSA/SHA256 signature Key ID FD531D51: BAD is there another way to fix this. I am beginner Linux user. Unfortunately I can not share screen shot as it is a classified server.

Responses

Hello,

Was RHEL6.6 or older minor release of RHEL6 used for the server? If not, the problem in nss-softokn-freebl should be fixed already. So, replacing the libraries upon https://access.redhat.com/solutions/1351243 doesn't help to resolve it.

Please check if the rpm gpg public key is imported properly to verify the package.

# rpm -qi gpg-pubkey-fd431d51-4ae0493b

If it's not imported, try this:

# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

Download any package from Red Hat Customer Portal, and verify the package for testing.

  # rpm -K <package>.rpm

For example, the following is the correct output. It may output any error in your case.

# rpm -K bash-4.4.19-6.el8.x86_64.rpm 
bash-4.4.19-6.el8.x86_64.rpm: rsa sha1 (md5) pgp md5 OK

It's needed to check your server configuration precisely and to do more testing and investigation, if these don't help at all. I recommend you to open a support case from here: https://access.redhat.com/support/cases/#/case/new