Package

Latest response

can any body tell how can I install this package on my rhel ,,,, it keeps telling me no package available. " libcrypto.so.1.0.0"
or this is the whole deatail error that I get

"./PacketTracer7: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory "

Responses

Your software is trying to load a library, not a package.

A library is a file shipped within a package. There will be an RPM somewhere with a libcrypto.so.X.Y.Z file.

We can use the package tools to find which package includes that file:

EL7 # yum provides "*/libcrypto.so.1.0.0"
...
No matches found

Okay, we don't ship that exact file.

Let's make our search less specific:

EL7 # yum provides "*/libcrypto.so*"
...

We get a few results, but the one we are interested in is this:

openssl-1.0.1e-57.el6.x86_64 : A general purpose cryptography library with TLS implementation
Filename    : /usr/lib64/libcrypto.so.10
Filename    : /usr/lib64/libcrypto.so.1.0.1e

So libcrypto.so.1.0.0 is from an older version of OpenSSL which isn't in EL7 anymore.

Your application is using outdated OpenSSL. The application needs to be updated (probably recompiled) to use a newer OpenSSL which is available on RHEL7.

Out of interest, very early RHEL6 did ship OpenSSL 1.0.0, but that has been updated since:

EL6 # yum provides "*/libcrypto.so.1.0.0"
...
openssl-1.0.0-27.el6_4.2.x86_64 : A general purpose cryptography library with TLS implementation
Filename    : /usr/lib64/libcrypto.so.1.0.0
EL6 # yum list available --showduplicates openssl | tail -1
openssl.x86_64               1.0.1e-57.el6                    rhel-6-server-rpms

Strong recommend NOT to intentionally install an old, outdated, vulnerable version of OpenSSL so you could run a program called "packet tracer" which sounds like it blindly accepts packet data, which provides a big attack surface. That's potentially a very bad idea.

Hi Jamie,

Thank you very much for this comprehensive explanation - very useful ... especially for new users of RHEL ! :)

Regards,
Christian

Thank you Sir I have been away to windows since Packet Tracer won't work on Red Hat Linux and came back and found your detailed explanation why I couldn't run my app because of the outdated libraries ...I will try to update the Software and see if it can share from the new Openssl libraries on EL7.

Best Regards

Girma

[root@girma bin]# ./PacketTracer7 ./PacketTracer7: ./libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7) ./PacketTracer7: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./PacketTracer7) [root@girma bin]# packettracer Starting Packet Tracer7

nothing runs ... I am going back to Windows since I have to train on this Packet tracer for those who never heard about it ...it's a simulation application for cisco networking devices to practice and do some projects on Cisco proprietary courses.

So I really need it .... So I need help on this if u guys out there Red Hat Gurus want not to see me go back to Windows.

Thank you

Hi Girma,

You don't have to go back to Windows, just install Windows in a virtual machine and run the Cisco Packet Tracer application from within there. Red Hat Enterprise Linux comes with virtualization capabilities out-of-the-box, KVM is included in the Linux kernel. Install the virtualization group and you are ready to go ... this would be the most proper way to get "the best of both worlds". :)

Regards,
Christian

Thank You Christian ... I have Red Hat on my Windows OS on a Virtual Machine. I just wanted the packettracer to work on my RHEL that I use as a dual boot on my PC cause I have limited resourses I let RHEL to take over all the resources on my PC.

I haven't used Packet Tracer before but GNS3 runs well on Linux to simulate Cisco gear. You just need IOS images, which you will have access to with a valid Cisco account.

Thank You Jamie for the recommendation but the latest IOS version comes wiz cost $199 and cisco removed the previous versions but I will definitely have GNS3 once I get the $,

Thank You

Girma

I've trying to download the following packages;

libssl.so.10 libcrypto.so.10 libaio.so.1 Someone should please help out. Thank you.

Hi Akinyemi,

Please open a new discussion thread ... this one is nearly three years old and much has changed since. Thank you ! :)

Regards,
Christian

Hi Akinyemi,

Thank you for having followed my recommendation ... I have provided you with the answer in your new discussion. :)

Regards,
Christian