Google Chrome RHEL 7.6 install issue

Latest response

Hi, I tried to install Google Chrome to RHEL 7.6 and got this message: "Public key for google-chrome-stable_current_x86_64.rpm is not installed" What can I do to get this installed? Thanks very much! :)

Responses

I am also getting this error:

Error: Package: google-chrome-stable-70.0.3538.77-1.x86_64 (/google-chrome-stable_current_x86_64) Requires: liberation-fonts You could try using --skip-broken to work around the problem su You could try running: rpm -Va --nofiles --nodigest

I hope I am doing it right, if anyone knows the right commands, on how to install Google Chrome I would greatly appreciate it! :D

Hi GD,

The package liberation-fonts is available in the optional repository - execute these commands to install Google Chrome :

sudo subscription-manager repos --enable rhel-7-server-extras-rpms sudo subscription-manager repos --enable rhel-7-server-optional-rpms

Additionally I recommend to add the EPEL repository ... this repository might be needed for installing other applications later on.

sudo rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Add the Google Chrome repository :

sudo vi /etc/yum.repos.d/google-chrome.repo

Insert the following lines :

[google-chrome]
name=google-chrome
baseurl=https://dl.google.com/linux/chrome/rpm/stable/$basearch
enabled=1
gpgcheck=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub

Now update the software sources and install the application :

sudo yum update
sudo yum install google-chrome-stable

Regards,
Christian

This worked! You are very helpful, thanks! :)

You're welcome, GD - I'm glad that you appreciate our assistance ! :)

Regards,
Christian

Thank you, clear and concise. This was exactly what I needed.

You're welcome, Benjamin ! Glad to read it's meeting your needs. :)

Regards,
Christian

Hi CL, Is there any way to fix this issue when you don't have subscription and in absence of this I am getting below error while trying to install chrome on rhel 7.6. Appreciate your advise.

bash-4.2# subscription-manager repos
This system has no repositories available through subscriptions.

--> Finished Dependency Resolution Error: Package: cairo-gobject-1.14.8-2.el7.x86_64 (rhel) Requires: cairo(x86-64) = 1.14.8-2.el7 Installed: cairo-1.15.12-3.el7.x86_64 (@rhel-7-server-rpms) cairo(x86-64) = 1.15.12-3.el7 Available: cairo-1.12.14-6.el7.x86_64 (rhel) cairo(x86-64) = 1.12.14-6.el7 Available: cairo-1.14.2-1.el7.x86_64 (rhel) cairo(x86-64) = 1.14.2-1.el7 Available: cairo-1.14.8-2.el7.x86_64 (rhel) cairo(x86-64) = 1.14.8-2.el7 Error: Package: google-chrome-stable-73.0.3683.86-1.x86_64 (/google-chrome-stable_current_x86_64) Requires: liberation-fonts Error: Package: libwayland-cursor-1.14.0-2.el7.x86_64 (rhel) Requires: libwayland-client(x86-64) = 1.14.0-2.el7 Installed: libwayland-client-1.15.0-1.el7.x86_64 (@rhel-7-server-rpms) libwayland-client(x86-64) = 1.15.0-1.el7 Available: libwayland-client-1.14.0-2.el7.x86_64 (rhel) libwayland-client(x86-64) = 1.14.0-2.el7 You could try using --skip-broken to work around the problem

Cheers! Sagar

Hi Sagar,

When you don't have a valid subscription, you can't install packages from the RHEL repos of course. :)

Regards,
Christian

Worked perfectly on rhel 7.6 Thanks a lot.

You're welcome, Geir ! :)

Regards,
Christian

Thanks Christian Labisch. I was wondering about the repo for the fonts. :)

You're welcome, Anthony ! :) Fonts ? ... not sure what you mean ... Chrome uses the fonts which are installed and available. If you want to use other fonts that are not available from the repositories, just install them manually. :)

Regards,
Christian

Sorry to be unclear. I meant I didn't have the optional-rpms repo enabled so I didn't know where to get the liberation-fonts.

Ah, okay ... no problem, Anthony ... thanks for clarifying what you meant ! :)

Regards,
Christian

Hi Christian. Followed your instructions (already tried some other solutions found elsewhere) but after "yum update" I keep getting: google-chrome | 1.3 kB 00:00:00
https://cdn.redhat.com/content/beta/rhel/workstation/7/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden Trying other mirror. To address this issue please refer to the below knowledge base article

https://access.redhat.com/solutions/69319

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

One of the configured repositories failed (Red Hat Enterprise Linux 7 Workstation Beta (RPMs)), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=rhel-7-workstation-beta-rpms ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable rhel-7-workstation-beta-rpms
    or
        subscription-manager repos --disable=rhel-7-workstation-beta-rpms

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=rhel-7-workstation-beta-rpms.skip_if_unavailable=true

failure: repodata/repomd.xml from rhel-7-workstation-beta-rpms: [Errno 256] No more mirrors to try. https://cdn.redhat.com/content/beta/rhel/workstation/7/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden I guess there's something wrong with my repositories configuration...

Hi Michela, sudo yum clean all and sudo rm -r /var/cache/yum should solve the problem. :)

Regards,
Christian

Solved! Sorry I missed the link https://access.redhat.com/solutions/69319 Followed those instructions, redid your procedure and everything worked out! Thanks anyway, Michela

You're welcome, Michela ! Glad to read that you solved the problem and that everything works now. :)

Regards,
Christian

Thank you for this post and solution, I was able to get chrome installed on 7.6.

You're welcome, Samuel ! :)

Hi All, I am getting below error while trying to install Chrome on "Red Hat Enterprise Linux Server release 7.6 (Maipo)" using command as "yum -y localinstall google-chrome-stable_current_x86_64.rpm".

Error ----

Error: Package: google-chrome-stable-73.0.3683.86-1.x86_64 (/google-chrome-stable_current_x86_64) Requires: liberation-fonts

You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Please suggest to fix this.

Cheers! SG

Hi Sagar,

Seems the repositories I mentioned in my first post are not enabled ... please follow the instructions I've provided. :)

Regards,
Christian

Exact and concise solution really needed to appreciate.

Thanks for your feedback, Hafiz ! Glad you appreciate the solution. :)

Regards,
Christian