Sound issues with RHEL7.5

Latest response


I have this very frustrating issue of having absolutely no sound on my brand new laptop. My laptop is a brand new Metabox PrimeS P950EP.

I have tried things that have been mentioned online to fiddle with resolving the sound issue and have managed to kill the system couple of times.

I desperately need the sound issue solved.

I tried installing CentOS and Fedora 28 and both has no sound either.

In the Settings, Sound, Output tab it has 2 listings:

  1. Digital Output (S/PDIF) - Built-in Audio and a corresponding Profile of "Digital Stereo (IEC958) Output

  2. Speakers - Built-in Audio and a corresponding Profile of "Analog Stereo Output"

Could anyone shed some light on my problem? Or guide me to links etc. where I can read more about it?

Thank you so much.


Hi Philip,

Most probably you're facing a hardware related issue with the sound drivers, which might not support your audio chip.
What makes it even more certain is the fact that you are having the same problem on fedora - which is very unusual ...
There might be a slight chance that it can be solved by adding a special kernel parameter. I suggest that you search in
the archlinux wiki for a possible solution, it is known for offering good documentation for "bleeding edge" problems. :)


Hi Christian! Thank you so much for your reply. I have the same issue with Redhat and Fedora 28.and now it fixed.

You're welcome ! :)

Hi Christian! Thank you so much for your reply. At least one person replied! :)

So, I tried several different Linux flavors all to have errors whilst installing or installing with various hardware issues.

I didn't give up and tried Fedora 28. I read that if you want "cutting edge" stuff, venture into Fedora. At first, it installed fine however, I still had no sound. I thought damn, not again! Well, I told myself to do an update so did an update. It had nearly 400mb of updates and whilst that was installing I could see the Pulseaudio updates as well.

I rebooted my laptop and tested my sound and guess what, the sound works perfectly now. Thank you baby Jesus! :)

I'm now a very happy man and I absolutely love Fedora with KDE. So many amazing tweaks you can do with KDE. I'm in love!!!!

Thank you so much once again for reaching out.


Hi Philip,

You're welcome ! I'm glad to read that you could get the sound issues sorted out on fedora ... enjoy the system. :)


This fixed my problem:

1) Append snd_intel_dspcfg: dsp_driver=1 to GRUB_CMDLINE_LINUX_DEFAULT inside /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/YOURS_PARTION_UUID splash=silent quiet showopts snd-intel-dspcfg.dsp_driver=1"

2) sudo grub2-mkconfig -o /boot/grub2/grub.cfg 3) Reboot

Thanks. This solved the problem.

I am new to Linux ... I need your help to know which command should I use to know the right partition specially I have 2 HDD and more than one partition.


Also I would like to share that sound was working before properly and after update it is only work on the headset the main speaker there is no sound and I cant find the driver when I open the sound setting.

I installed windows on other partition and it work fine.


Hi Wagea,

Please open a new discussion ... this one is nearly 3 years old - and your issue might not be related. :)


Hi Muntashir,

Please open a new discussion, as you issue is not sound related.


Jan Gerrit

Hi Jan,

Muntashir said "Thanks. This solved the problem." So why should he open a new discussion ? :)
Possibly you meant Wagea Allam ? In case you did, I agree with you, he should start a new one.


Hi im usama 12 years old kid, im new in Redhat OS im facing sound issues, like i couldn't hear any music. Moreover, whenever i plug my headset they don't show in sound settings......

help me to solve this issues

step-by-step guide

Hi Usama,

It can be "this and that" ... Please open a new discussion and provide more information about your system setup. :)