Yum Update fails with https://cdn.redhat.com/content/dist/rhel/server/7/7.4/x86_64/os/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found

Latest response

Working on a new 7.4 build and after getting it registered when attempting to update the system it errors out.

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
https://cdn.redhat.com/content/dist/rhel/server/7/7.4/x86_64/os/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

rhel-7-server-rpms | 3.5 kB 00:00:00

One of the configured repositories failed (Red Hat Enterprise Linux 7 Server (RPMs)),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=rhel-7-server-rpms ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable rhel-7-server-rpms
    or
        subscription-manager repos --disable=rhel-7-server-rpms

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=rhel-7-server-rpms.skip_if_unavailable=true

failure: repodata/repomd.xml.asc from rhel-7-server-rpms: [Errno 256] No more mirrors to try.
https://cdn.redhat.com/content/dist/rhel/server/7/7.4/x86_64/os/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found

Have tried the different articles and nothing. Was wondering if anyone else has run into or if there is something that I'm missing. Thanks.

Responses

Hello,

You say "Have tried the different articles", does that include this one: Red Hat Knowledgebase solution yum fails with error "[Errno 14] HTTPS Error 404 - Not Found" on Red Hat Enterprise Linux 7. ?

Hi William,

The commands which often solve this problem (they are both included in the linked article Stephen provided above) are :
sudo yum clean all | sudo rm -r /var/cache/yum. Additionally check the repo file configs in /etc/yum.repos.d ... :)

Regards,
Christian

Cheers all,

We experienced the same, infuriating issue and the resolution as prescribed in Akash's solution link (2850911) fixed it: "As GPG armor is not enabled on server side, so ensure repo_gpgcheck is set to 0 in yum.conf file for RHEL clients."

Best, Clay.

it does not help me.... tried all you have tried and than some more and still no way to get one client to run "yum update".... and the premium support is just wonderful :-)

I kept having same issue for some reason when i did

 yum list

after the

sudo yum clean all | sudo rm -r /var/cache/yum 

all problems went away, maybe helpful to you all

Leo, did you take the security recommendation at face value for repo_gpgcheck set to 1 in /etc/yum.conf? That ultimately results in this issue every time, even for RHEL 7.

Run this command

grep repo_gpgcheck /etc/yum.conf

If it shows "1", then please examine this solution id: https://access.redhat.com/solutions/2850911.

There are various security guides that state to set that value to 1 which results in this issue.

Change it to "0" as described in the article, then do a yum clean all; yum repolist and see if you get the same results.

If not, open a case with Red Hat

Regards

RJ

None worked for me. Rhel is so much more work than Ubuntu

I don't think so, James ... did you never run into one of those nasty apt/dpkg dependency issues ? :D :D :D

Cheers :)
Christian