NO MORE MIRRORS TO TRY

Latest response

Total size: 690 M
Total download size: 12 M
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for rhel-7-server-rpms
gnome-settings-daemon-3.22.2-5 FAILED 10% [========== ] 275 kB/s | 1.3 MB 00:00:40 ETA
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os/Packages/gnome-settings-daemon-3.22.2-5.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=rhel-7-server-rpms clean metadata
Trying other mirror.
gnome-getting-started-docs-3.2 FAILED 41% [======================================= ] 455 kB/s | 5.1 MB 00:00:16 ETA
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os/Packages/gnome-getting-started-docs-3.22.0-1.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=rhel-7-server-rpms clean metadata
Trying other mirror.

Error downloading packages:
gnome-getting-started-docs-3.22.0-1.el7.noarch: [Errno 256] No more mirrors to try.
gnome-settings-daemon-3.22.2-5.el7.x86_64: [Errno 256] No more mirrors to try.

Responses

Hi Izuchukwu,

Please clean up yum completely and try again, execute the following commands :

sudo yum clean all | sudo rm -r /var/cache/yum | sudo yum update

Regards,
Christian

Hi Christian,

i'll try and still "[Errno 256] No more mirrors to try".

Thank You

Hi Valentinus,

Please check if the system is correctly registered and the subscription attached - if it is the case and running
the commands again after waiting some time (it might be a temporary issue with the Red Hat update servers)
still doesn't solve it, contact Red Hat Customer Support and/or open a support case. I wish you good luck ! :)

Regards,
Christian

Hi Valentinus,

What does the following command show?

subscription-manager repos --list-enabled

Regards,

Jan Gerrit

Hi Valentinus,

Please clean up yum completely and try again, execute the following commands :

sudo yum clean all

The remount you local repo

sudo mount /dev/sr0 /mnt (The /mnt is where you mount the local repo, on my machine it is /mnt)

them check the repolist

sudo yum repolist

Hope this helps

Regards,

Hi Valentinus,

Try if this can help.

  1. Disable the repository, so yum won't use it by default. Yum will then just ignore the repository until you permanently enable it again or use --enablerepo for temporary usage: #yum-config-manager --disable RHEL7-Server-DVD

  2. Configure the failing repository to be skipped, if it is unavailable. Note that yum will try to contact the repo. when it runs most commands, so will have to try and fail each time (and thus. yum will be be much slower). If it is a very temporary problem though, this is often a nice compromise: #yum-config-manager --save --setopt=RHEL7-Server-DVD.skip_if_unavailable=true