Cannot Activate RHEL Server with Free Developer Subscription

Latest response

I signed up for the free Red Hat developer license, but I can't activate my RHEL server install. My account says I have an active Red Hat Enterprise Linux Developer Suite subscription, but when I go to attach my system to it, I get a message saying I don't have any matching subscriptions.

Has anyone else had this problem?

Responses

Hi James,

It happens randomly every now and then ...
You should be able to solve it by executing :

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

Regards,
Christian

Just wanted to say that I had the same issue, in my case your instructions worked and I now have repositories.

That's great, James ! I'm glad that it worked for you. :)

Regards,
Christian

Thank you very much Christian! it worked like a charm! going crazy looking for a solution and found yours! thanks!!!!

You're welcome, Sivavathan ! I'm glad that the instructions were useful for you. :)

Regards,
Christian

You're welcome, Richard ! :)

Worked perfect for me. I accidentally entered my email as well but this fixed it for me.

You're welcome, Allen ! Glad you could get it done. :)

Worked great! Thank you!

Great ! You're welcome, Rouslan ! :)

Great Christian... This worked for me. Kudos!

Thanks, Najam ! I'm glad it helped you. :)

Hi Christian,

Thank you for the response. I tried the commands you listed, but I was still not able to register.

This was the result I got:

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.

Hi James,

In this case you should contact the Custumer Support team to let them have a look into the issue and fix it for you. :)

Regards,
Christian

Edited: Oops, I found out that I shouldn't have tried with my email address as the username. Now I'm registered. Thank you!

Hi Christian,

I've got the same issue as this thread, getting "Invalid user credentials" while trying to register. I put my email as username and my password to www.redhat.com to register. So I tried to contact the Customer Support you mentioned but it says although my credential is valid, i have no access to red hat direct support. Yes, the subscription I've got is for developer. Do you have any suggestions?

Hi Qi,

You're welcome ! Glad you could get it done - what make me wonder though, subscription issues
are covered by Red Hat Support for every edition (including the Developer Subscription). Either
the support assistant was very new in his job role or he must have misunderstood something ... :)

Regards,
Christian

Hi Christian, Thank you for your reply. As not being a local English speaker I might have introduced misunderstanding. I tried the link you provided and got 3 options in red buttons: "OPEN NEW CASE", "LEARN MORE", "CONTACT US". So I clicked the "OPEN NEW CASE" button and the web page says "The credentials you provided are valid, but you do not have direct support from Red Hat." (copy/pasted). Thank you very much anyway.

Hi Qi,

Got it ... no, you should not open a case, instead you should contact Customer Service via mail. :)

Regards,
Christian

Hi James, I just gotta ask, is there any chance you have a network issue preventing you from reaching Red Hat?

Out of abject curiosity, examine this https://access.redhat.com/labsinfo/registrationassistant

As one Red-Hatter (Stephen Wadeley) mentioned in a like issue, One possible cause could be if your system has more sockets than the entitlement allows. You can check determine that with this How to determine the number of CPUs on a system https://access.redhat.com/solutions/61791

Lastly, if you did register it, but just can not attach entitlements, have you tried manually attaching them through the Customer portal? Here's how:

you can attempt to set its' channels through the Red Hat Customer Service area. Did you go through this solution https://access.redhat.com/solutions/1735723? Also examine this solution at https://access.redhat.com/solutions/321033.

If this system is connected directly to Red Hat, then go to the Red Hat Portal main page. Look for a link named "My Subscriptions" and click on it, then go to the link named Systems which leads to https://access.redhat.com/management/systems. See if your system is there. IF IT IS, then click on the link with the name of the specific server. This should land you on the "Details" tab. Next to that, look for a tab that says "Subscriptions" and click on that link. (important note below) There ought to be a dark button that is named "Attach Subscriptions"

Okay, I went through this, and the link "Attach Subscriptions" wasn't working, so I deleted the subscription from the system itself, then I re-added it and was able to have the subscription re-added. Then go to the server in question and run subscription-manger refresh;yum clean all;yum repolist

Again, let us know how it goes.

Hi R. Hinton,

There was no network issue on my end and I had tried to manually attach the subscription via the customer portal to no avail. In the end, I got in touch with Red Hat Customer Support and they sorted it out on their end.

Hi James,

Good to read that the Customer Support team could solve your problem. :)

Regards,
Christian

I am glad they got it sorted out for you,

besides my curiosity, others may come to this discussion you started, and wondered what the resolution is? What did they do to resolve the issue

Thank you for letting us now

I believe they had to remove the license from my account and then add it again.

yup, that's clearly something on their end. Thanks Christian for the good tip for James.

Hi ! :)

I'm glad that we could help James to solve it. The thing is that when the commands I provided in my first post above can't fix this special problem, there is no other chance than asking the support team to do that and I assume that it has something to do with the Developer Edition being not a "normal" subscription which (under the hood) might be attached in a different way ... strange is that it occurs randomly for only some users though. I am talking about the free no-cost Developer Suite of course.

Regards,
Christian

I got this problem in developer RHEL;

[root@generic ~]# yum repolist

Updating Subscription Management repositories. This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions. No repositories available

what should i do?

Hi Greesh,

Eventually the pool isn't properly attached ? Execute the commands I provided in my first response above.
But instead of option attach --auto use attach --pool=<Pool-ID> Check for the matching ID with sudo subscription-manager list --available. If that doesn't work - contact Customer Support. :)

Regards,
Christian

Having the same issue with RHEL 8.2 Beta...

Hi Jakub,

You need a dedicated Red Hat Beta subscription. Once you have it, attach it as being explained to Greesh above. :)

Regards,
Christian

Hello Christian.

I've just discovered that :) Thanks for the quick response though.

Also, I did send an email to sales ... so I dont know the requirements to get the beta subscription yet.

I think there is a bug in iostat... so I wanted to download the RHEL 8.2 Beta to test it.

Hi Jabub,

You may want to read this discussion entirely ... :)

Regards,
Christian

Hi Jakub,

For your convenience ... here is the 8.2 beta link. :)

Regards,
Christian

@christian! I've just received that subscription.

THANKS AGAIN! Everything is working ATM:

[root@localhost ~]# subscription-manager attach --auto Installed Product Current Status: Product Name: Red Hat Enterprise Linux for x86_64 Beta Status: Subscribed

You're welcome, Jakub ! :)

just tested the iostat. Behaves as in Centos 8/8.1. Gonna report it to bugzilla.redhat.com

Hi, I'm trying to register a new system that has RHEL 8.1 , I used sudo subscription-manager register, entered my redhat portal username (my email) and the password, it chugs for a minute and replies with: "HTTP error (401 - Unauthorized): authorized" I'm confused by the reply, and have tried more than once. System still reports as not registered. What simple step am I missing? Thanks.

As far as I remember I had to use my username/nick.. not email.

Hi Jakub, Thanks! That did it.

You're welcome! :)

I have a issue, i could installed rhel 8.1, but can't register with the red hat portal.

[root@localhost ~]# subscription-manager register Registering to: subscription.rhsm.redhat.com:443/subscription Username: Password: The system has been registered with ID: The registered system name is: srv-test [root@localhost ~]# [root@localhost ~]# subscription-manager refresh All local data refreshed [root@localhost ~]# subscription-manager attach --auto Installed Product Current Status: Product Name: Red Hat Enterprise Linux for x86_64 Status: Not Subscribed

Unable to find available subscriptions for all your installed products. [root@localhost ~]# [root@localhost ~]# subscription-manager list --available No available subscription pools to list [root@localhost ~]# [root@localhost ~]# cat /etc/redhat-release Red Hat Enterprise Linux release 8.1 (Ootpa) [root@localhost ~]#

Francisco,

From your text above, it looks like you registered it.

  • Excerpt from your output in your post above mine, I copied/pasted it.
The system has been registered with ID:

Try what Christian Labisch mentioned above. One post he writes says to try this:

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

His next reply to someone was to contact customer support. I recommend starting with those steps Christian Labisch recommended earlier in this iscussion. If needed, contact Red Hat support and submit a case..

Regards,
RJ

Be careful with your subscriptions! Like if you have a developer and beta sub. also, the auto-attachment maybe will not work. But you can attach to the desired pool directly and things should work. ;)

Hi András,

Yes, in this case better execute sudo subscription-manager attach --pool=<Pool-ID> ... :)

Regards,
Christian

After attempting these steps on both RHEL 7 and RHEL 8 I ended up having to create a new Red Hat Developer account in order to attach my subscription. My old account was created in 2017 and worked with a previous install but would simply refuse to work with a new install.

Thanks, worked perfectly!

You're welcome, Kerstan ! Glad we could help you. :)

Hello I have the issue with registration either I am getting the error that the object is not subsritable or I need to provide some organisation unit in gui nothing is working for me. any ideas ?