subscription-manager repos --enable <repo> not working

Latest response

Hi guys,
I'm trying to run subscription-manager repos --enable command but it shows message [bash: syntax error near unexpected token 'newline'].
You'll be highly appreciated for this help.

Responses

Hi Chandra,

Which repository are you trying to enable?

Try without specifying a repository. If you get the output below, it is likely something is not right with the repository name you are using.

# subscription-manager repos --enable
Usage: subscription-manager repos [OPTIONS]

subscription-manager: error: --enable option requires an argument

Hi Chandra,

Here is an example in addition to what Sam explained, please execute these commands :
(replace 'server' with desktop or workstation in case you are using one of these editions)

sudo subscription-manager repos --enable rhel-7-server-extras-rpms
sudo subscription-manager repos --enable rhel-7-server-optional-rpms

What do you get from sudo subscription-manager repos --list-enabled then ?
When the two repositories are included in the output, everything works as expected. :)

Regards,
Christian