Solution: specific conditions after registering RHEL 6.9 system to a Satellite 6.2.x server, can not perform yum actions

Latest response

I'm posting this for specific conditions for RHEL 6.9 servers. After registering them to my satellite 6.2.11 server, some of my systems could not perform yum operations. For my own circumstances, my solution that fixed the issue I had is below.

RHEL 6.9 servers
Disconnected network, with Satellite 6.2.11 on rhel 7.current
Successful creation of content views for RHEL6 server
Successful creation of activation key properly ascribing channels to content view.
Successful assignment of entitlements (fully entitled)
Products show properly the correct channels are enabled, and the unneeded channels are disabled.

A few of my own systems after successful registration to my satellite server would not perform yum operations, even though they would not perform any yum operations. I scoured google, Red Hat and more.

I finally tried "subscription-manager config" command and noted the following difference between the systems that did and did not work:
The systems that DID work had "manage_repos = 1" in the /etc/rhsm/rhsm.conf file. The ones that DID NOT work had a "0" instead of a "1".

As soon as I changed the "0" to a "1", yum operations worked again (perhaps with subscription-manager refresh and yum clean all;yum repolist)

Now will this cure every instance of yum not working after registering to a satellite? no. It did however assist in the very specific set of circumstances I had (rhsm.conf file had manage_repos =1 to make it function properly).

Responses

Was manage_repos ever explicitly set to 0 ? The default configuration of subscription-manager is to manage repos manage_repos = 1 (read: write and manage the /etc/yum.repos.d/redhat.repo file). And once set, the configurations are never overridden. The only time that setting that value to 0 would make sense is if you wanted to register via subscription-manager to track entitlements, but you didn't want to use the repos provided by Satellite. (Which is kind of an exotic use-case).

Hi Rich, appreciate you chiming in here. I don't personally recall ever setting that to a value of 0, I did note an "rpmsave" file for it. I'd have to check the changelog for the rpm. I'd be surprised if any of my coworkers would do this without any discussion either. It's a bit of a puzzle. By the way, really like your satellite content view export. I've got a ticket in with Red Hat hoping they make the default export instructions in the official documentation to match yours, the current documentation has one-channel-at-a-time which has a myriad of unacceptable consequences. Love the solution you provided.

I checked the changelog for the subscription-manager rpm (which provides /etc/rhsm/rhsm.conf), and saw at least nothing documented against that sort of change. The "rhsm.conf.rpmnew file I found on the systems affected was dated March if 2016 (system built 2015, rhel server EL6). The corresponding changes in the changelog of the rpm do not show anything roughly around that time.

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.