Encrypting SAML Request

Latest response

Hi,
I am facing an issue with my SAML configuration in WildFly 10.0
I have configured SAML using picketlink.xml
Functionally it is working as expected, but I am able to decode the SAML request easily since it is not encrypted.
So When I tried to encrypt I am not able to achieve this.

Steps Tried:
1.Added Encrypt="true" and SupportsSignature="true" in PicketLinkIDP tag
2.Added two handlers for encryption.

https://docs.jboss.org/author/display/PLINK/Identity+Provider+Configuration#IdentityProviderConfiguration-SAMLEncryptionConfiguration

But still it does not work. Is there anything that I am missing or needs to be configured?

Responses

Hi Muralidhar,

This discussion forum is mainly for users of JBoss EAP. If you are wanting some help with WildFly, you will probably get a better response in the WildFly discussion forum at the JBoss Developer site: https://developer.jboss.org/en/wildfly?view=discussions

If you are using JBoss EAP, we have docs for configuring SAML assertion encryption in JBoss EAP 7.0 here: https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.0/html-single/how_to_set_up_sso_with_saml_v2/#saml_assertion_encryption