Add user storage in User Federation

Latest response

Hi All,

I am able to add provider through UI but I need help to add through CLI due to automation.

I am using REDHat SSO 7.1 and when tried to execute cmd

              kcadm.bat create user-federation/instances -r Test4 -s providerName=my-provider -s priority=0 -s config.debug=false

Resource not found for url: http://localhost:8080/auth/admin/realms/Test4/user-federation/instances

Is there any Json that I can execute?

Responses

Hi Sarada,

I face the same problem here. I followed the documentation here, set up a demo realm and tried to execute:

$ kcadm.sh create user-federation/instances -r demorealm -s providerName=kerberos -s priority=0 -s config.debug=false -s config.allowPasswordAuthentication=true -s 'config.editMode="UNSYNCED"' -s config.updateProfileFirstLogin=true -s config.allowKerberosAuthentication=true -s 'config.kerberosRealm="KEYCLOAK.ORG"' -s 'config.keyTab="http.keytab"' -s 'config.serverPrincipal="HTTP/localhost@KEYCLOAK.ORG"'

But only got:

Resource not found for url: http://0.0.0.0:8080/auth/admin/realms/demorealm/user-federation/instances
command terminated with exit code 1

@KeyCloak: Any ideas?