UI language of Red Hat Web pages goes crazy!

Latest response

The Web interface of RHN, RHSM, and RH Customer Portal has its language going crazy:

  1. Language changes randomly:
    No matter if I switch between pages or refresh the same page, no matter if I let the language be default or intentionally chose a language on menu, I usually see the displayed language changes randomly, and uncontrollably.
    I've check the request cookie and it correctly reflects my choice of language: If I let the language be default (from a fresh restart of browser) then no "rh_locale" entry is defined; If I chose one language on the menu, the "rh_locale" entry in the cookie reflects my choice. However the displayed language is nondeterministic!

  2. Inconsistent languages between Headers (Products & Services, Tools, Security, Community), Utility bar and the Main body content:
    For example when Japanese is chosen and displayed,

    • https://access.redhat.com/errata/RHSA-2017:0170 shows English headers, English unitility bar (with "English" is displayed as the chosen language in Language menu), and Japanese body content; while
    • https://rhn.redhat.com/errata/RHSA-2017-0170.html shows Japanese headers, Japanese unitility bar (with "Japanese " is displayed as the chosen language in Language menu), and English body content.
      *) As described in number 1, the chosen language is not always the displayed one.

==> I want a consistent language through out the time. Is there any way to constrain the Web pages to display only English?


Update on June 28th: Thanks to Sam Wachira's suggestion about the Locale preference, I've re-tested the RHSM Web UI with stable result when logged in & locale preference set. But right after I logged out, the UI language went back to random behaviour. Here I upload an archive of screenshots of each step in my test:
- 0x: Open erratum RHSA-2017:0244 in a new (fresh) browser (Google Chrome). Just refresh ==> random languages;
- 1x: Choose "English" ==> still random languages;
- 2x: Log in & set locale preference (language = "English") ==> seems to be stable!
- 3x: Log out ==> back to random!
- 4x: Log in & 5x: set locale preference language = "French" ==> seems to be stable!

Attachments

Will Le's picture

Responses

Hi Will,

Inconsistent languages between Headers and Main body content - Only an issue for me when English is not the preferred language. Select English as the preferred language, and it should display all contents in English.

You could also check your desktop and browser language preferences.

Hi Sam,

I can confirm what Will described in his post - the other day when I opened a security advice link, the content was shown in different languages even though everything is set to English language as default on the system. I shared the link with a friend living in London, GB - same issue. I guess this must be a randomly appearing problem with the website ... it only occurred on that one day though.

Cheers :)
Christian

Hi Sam,

Thank you for your information about the Locale preference. It seems to stabilize the Web language. I've updated the main post with a detail test with screenshots.

You are welcome. Thanks also to ir. Jan Gerrit Kootstra for raising support case 01879765

Hi Gents,

Both at the office in The Hague and at home in Pernis, municipality Rotterdam in The Netherlands running Firefox on RHEL 6.9 server or Windows 7 I face the same issue. Multiple days in a row.

Regards,

Jan Gerrit

Hi Jan Gerrit,

Thanks for sharing this information, I want to add that it occurred in Chromium web browser on fedora 25 as well.

Cheers :)
Christian

To get attention from Red Hat support, I created a support case: 01879765. Will keep you posted.

Thank you, Jan Gerrit ! :)

Unfortunately the case 01879765 has not been solved by now. I will request a management escalation.

I opened the case under a login that has only Standard support, so the escalation manager replied that they were working on this issue under the SLA conditions. Still no solution provided.

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.