Satellite 6.2.9 virt who is failing to send report

Latest response

Hi

I have an new installation of Satellite server 6.2.9 on RHEL 7.3 It will be replacing our existing Satellite server 6

main difference between setups is that o new setup virt-who is running with the satellite server

When I start the virt-who service I get the following error.

2017-05-19 11:03:55,427 [virtwho.init DEBUG] MainProcess(1472):MainThread @executor.py:init:66 - Using config named 'dubppvc01'
2017-05-19 11:03:55,428 [virtwho.init INFO] MainProcess(1472):MainThread @main.py:main:165 - Using configuration "dubppvc01" ("esx" mode)
2017-05-19 11:03:55,428 [virtwho.init INFO] MainProcess(1472):MainThread @main.py:main:167 - Using reporter_id='dubrh-satserver-62.office.local-d6270d40eeff4e1795b368a056d921b6'
2017-05-19 11:03:55,430 [virtwho.main DEBUG] MainProcess(1472):MainThread @executor.py:run:176 - Starting infinite loop with 3600 seconds interval
2017-05-19 11:03:55,473 [virtwho.dubppvc01 DEBUG] Esx-1(1482):MainThread @virt.py:run:379 - Virt backend 'dubppvc01' started
2017-05-19 11:03:55,474 [virtwho.dubppvc01 DEBUG] Esx-1(1482):MainThread @esx.py:_prepare:128 - Log into ESX
2017-05-19 11:03:55,654 [virtwho.dubppvc01 DEBUG] Esx-1(1482):MainThread @esx.py:_prepare:131 - Creating ESX event filter
2017-05-19 11:03:57,109 [virtwho.dubppvc01 DEBUG] Esx-1(1482):MainThread @virt.py:enqueue:372 - Report for config "dubppvc01" gathered, putting to queue for sending
2017-05-19 11:03:57,149 [virtwho.main DEBUG] MainProcess(1472):MainThread @subscriptionmanager.py:_connect:120 - Authenticating with RHSM username virt_who
2017-05-19 11:03:57,156 [virtwho.main DEBUG] MainProcess(1472):MainThread @executor.py:send_report:109 - Report from "dubppvc01" failed to sent

And my ESX hosts are not listed.

Here are detals of my /etc/sysconfig/virt-who

# Enable debugging output.
VIRTWHO_DEBUG=1

# Send the list of guest IDs and exit immediately.
#VIRTWHO_ONE_SHOT=0

# Acquire list of virtual guest each N seconds, only sends if changes detected
# 0 means default configuration.
#VIRTWHO_INTERVAL=0

# Virt-who subscription manager backend. Enable only one option from the following:
# Report to Subscription Asset Manager (SAM) or the Red Hat Customer Portal
# VIRTWHO_SAM=1
# Report to Satellite version 6
VIRTWHO_SATELLITE6=1
# Report to Satellite version 5
# VIRTWHO_SATELLITE5=0
# Report to Satellite [Legacy]
# VIRTWHO_SATELLITE=0

Here is my /etc/virt-who.d/Vcenter.conf (the only config file

[dubppvc01]
type=esx
server=vcenter.office.local
username=rhel-virt-who
#password=
encrypted_password=582c6300079d19b349ee7741f4b01cde
owner=RHEL-License
env=Library
hypervisor_id=hostname

rhsm_hostname=10.5.5.70
rhsm_username=virt-who
rhsm_encrypted_password=dbf788009a73712f4e85d54d5e41a761
rhsm_prefix=/rhsm

Our Vmware environment is ussually in lockdown mode but I have disabled it for several ESX hosts but I still get no hosts discovered.

Any help will be appreciated.

regards
Philip

Responses

couple extra notes 1: had to name the file in /etc/virt-who.d/XXXX.conf otherwise it does not recognize it 2: moved the following enstries to /etc/sysconfig/virt-who rhsm_hostname=10.5.5.70 rhsm_username=virt-who rhsm_encrypted_password=dbf788009a73712f4e85d54d5e41a761 rhsm_prefix=/rhsm

this enabled me to see my esx hosts in the rhsm.log but still getting the failed to sent

Failed to send reports may happen due to few different reasons.

  • Do you see any kind of authentication issue - similar to this
  • Also check out this article on troubleshooting virt-who connections

THhanks for replying,

I have looked at both articles before and unfortunately they do not apply.

Its not a problem with the user account in vcenter as that user was in use and working with our previous satellite server. Also after moviing the rhsm bits from file in /etc/virt-who.d/dubppvc01.conf I was able to see the list of ESX hosts and their VMs mentioned in the /var/log/rhsm/rhsm.log still not addde to my satellite server though

There is no active firewalls on the satserver or the vcenter and while they are on different subnets port 443 is open.

I have unregisterred the new satellite server from redhat and trying to set it up as self registerred to see if that helps

  • I see that you mentioned 2: moved the following enstries to /etc/sysconfig/virt-who rhsm_hostname=10.5.5.70 rhsm_username=virt-who rhsm_encrypted_password=dbf788009a73712f4e85d54d5e41a761 rhsm_prefix=/rhsm. As per the Satellite6 virtual instances guide this should be in your dubppvc01.conf file
  • You are right about naming the config file with .conf - this happened with recent virt-who release and the Satellite6 doc update bug is already created to track this issue.
  • Can you please double check if 10.5.5.70 is the right ip address of new satellite
  • also check if virt-who user is available in your new satellite with right permissions

Ok I have moved those lines back to my .conf file.

I have just checked the IP it is defintelly correct. I have tested using localhost also as both satellite server and virt-who are on same machine I have created a user virt-who on the satellite server. I was not able to follow the instructions from step 5.2 in https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/virtual_instances_guide/ as the gui link is broken. I have made it identical to the administrator and given it all roles. I have also tried using the administrator account with no luck

As a test I put the wrong password for the virt-who account and that gives me a fatal error. So it does appear to be authenticating but just able to send the report

I have rolled back on my install (its a VM so pretty easy to do)

I know have everything but virt-who working. Currently it it is asking me for proxy details. My satserver is not selfregisterred so this is expected.

I found article https://access.redhat.com/solutions/2026163 but it seems a bit dodgy. Is there sometyhing better?

now I get raise socket.error, "Proxy connection failed: %d" % code error: Proxy connection failed: 407 2017-05-22 17:08:52,328 [virtwho.main DEBUG] MainProcess(5801):MainThread @executor.py:send_report:108 - Report from "dubppvc01" failed to sent

I will create a bug for the broken url in virtual instances guide.

I didn't realize that you have a proxy in your environment between Satellite and the CDN - If so, virt-who will try to use it as well. I am not aware of any other documentation other than https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/virtual_instances_guide/#http_proxy and the one which you mentioned.

Since I am running out of ideas, it will be best if you can create a support ticket with necessary info.

Thank you for your help. I have now opened a SR for this.

Sounds great. I will try to follow up on the case and update the resolution here so it will be helpful to other users.

what was the fix? I have ythe issue as well

also need a fix for this problem

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.