mount error(112): Host is down

Latest response

Got the following error when trying to mount a CIFS file on RHEL 6.5:
[root@tama etc]# mount -t cifs --verbose -o username=goldengate_DBA //lacsqltzgprd4/GoldenGate /mnt/GoldenGate
Password:
mount.cifs kernel mount options: ip=10.50.243.13,unc=\lacsqltzgprd4\GoldenGate,,ver=1,user=goldengate_DBA,pass=********
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

It has been working fine until now. Not sure if it's a coincidence, but the problem started after we did the Kerberos password change over the weekend.
Thanks.

Responses

Hi,

try to enable more debug messages for the CIFS by running

echo 7 > /proc/fs/cifs/cifsFYI

to see additional error messages which may lead to to the cause.

When you are done, disable the debug by running

echo 0 > /proc/fs/cifs/cifsFYI

no addtl info found. thanks. Apr 15 17:56:07 tama kernel: CIFS VFS: cifs_mount failed w/return code = -112

This could be due to a protocol mismatch. In 2017 Microsoft released patches and advised to disabled SMBv1 .

I also got the same error "Host is down.", but when you debug using (-d debuglevel) as following you will find the root cause:

smbclient -L <server_name> -U <username> -d 256
protocol negotiation failed: NT_STATUS_CONNECTION_RESET

To overcome this use mount or smbclient with (-m maxprotocol)a protocol specified.

smbclient -L <server_name> -U <username> -m SMB2

or for mount: add vers=2.0 in the /etc/fstab

mount -t cifs -o vers=2.0 //<server_name>/<share> /<mountpoint>

Stil same issue, it didn't work for me.

I got this message yesterday Microsoft update windows - disabled SMBv1 - got host is down error - Opened case with redhat - They said that if you are running RHEL 4,5,6 - you can only use SMBV1 protocol - You would need to upgrade to RHEL7 to use SMBv2 or 3 https://access.redhat.com/solutions/1178753

I am using Red Hat Enterprise Linux Server release 7.1 (Maipo) but still the same error I am getting mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I am using the same in rhel6, but the output is showing unrecognised protocol error. Tried with SMB2.1, 2, 3 version.

 smbclient -L 192.xx.xx.xx -U username -m SMB2
Unrecognised protocol level SMB2
enter the user password;

help for the error below Mounting error (14): Incorrect address

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.