How to install GUI on RHEL 7.3 from command line

Latest response

Hello, I downloaded a trial of RHEL 7.3 and I'm trying to install it on VMWare. During installation, the first page with the server w/ a GUI option, skips by and I don't have time to change the settings. Then it goes to the page with setting root password and creating a user. I do that and continue installation till it finishes. It then takes me to a command line instead of the GUI. I need to know how to install a GUI from the line and possibly register my copy along the way. I've read to use "yum groupinstall 'Server with GUI'" but that says "no enabled repos" and it doesn't work. I managed to register my copy, but now it says it needs updates. Has anyone heard of this problem? Is there an easy way to install RHEL 7 with a GUI?

Responses

I've got no repos. I tried yum-config-manager --enable 'Server with GUI' and it didn't give any errors, it just went to the next line. But "yum groupinstall 'Server with GUI'" still doesn't work and it still shows 0 repos in list. Anyone?

Mike, check and make sure the system is registered. Refer the steps in this article https://access.redhat.com/solutions/8036

Once that is done successfully, check out the repos file, if not created then you may need create one as shown in this link (Example 8.25. A sample /etc/yum.repos.d/redhat.repo file)

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/sec-Configuring_Yum_and_Yum_Repositories.html

After which you may run "yum clean all" and then run "yum repolist" which would sync up with RHN and create the repositories. Later you may go ahead run "yum groupinstall "Server with GUI" which should work.

have you tried this ?

yum groupinstall gnome-desktop x11 fonts

Mike,

along with the above comments, examine this Red Hat solution: https://access.redhat.com/solutions/5238 (Mohd Shakiereen Zulkifli mentioned an important step that's in that article too) - recommend reading it through completely at least once before performing the steps.

Remember to see the steps in that article I mentioned: Set the system to boot directly into the GUI in RHEL 7: such as this and the following steps: systemctl set-default graphical.target after you perform that installation. Please see the remainder of that article.

Mike,

notice that you facing "no enabled repo"...have you check your subscription ?

i actually just installed oel 7.4 today, and upon performing yum update, got the same error,

then i do at the cli:

  1. subscription-manager register; you'll be prompt to login (login with my redhat login)
  2. subscription-manager subscribe
  3. yum update
  4. yum groupinstall gnome-desktop x11 fonts

for subscription check here: https://access.redhat.com/solutions/253273

then the oel will then boot to gui.. or you can do which R.Hinton suggest : systemctl set-default graphical.target..

Best Regards,

Great solution !

Easy to load & install x11 packages !

Thx Dominique

There might be a situation, where you are missing packages.

If you were to run the command above you may get:

# yum groupinstall gnome-desktop x11 fonts
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update

But there is missing packages, because of previous known commands. In this situation you can do following:

yum groupremove  gnome-desktop x11 fonts

and once completed, 
yum groupinstall  gnome-desktop x11 fonts

This should restore the missing package, that update or install didn't locate.

Red Hat subscription is always good, but if anyone can not perform it, however, I used the DVD installation media and made a local repo to install Graphics, fonts, KDE,GNOME etc.

Creating local media as repo: (RHEL 7) https://access.redhat.com/solutions/1355683

Creating local media as repo:(RHEL6) https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/installation_guide/sn-switching-to-gui-login

Then ran - yum groupinstall gnome-desktop x11 fonts