How do I access rhel-sap-hana-for-rhel-7-server-rpms repo on RHEL 7.2?

Latest response

Hi,

I'm trying to install BW/4HANA on my RHEL 7.2 machine. I try to perform the steps here: https://access.redhat.com/solutions/2334521
Everything works fine until
subscription-manager repos --enable="rhel-sap-hana-for-rhel-7-server-rpms"

It says it cannot find this repo. Do you know why this is? Has it been removed? Do I need special permissions?

Thank you!

Responses

Do you have a Red Hat Enterprise Linux for SAP HANA subscription on your system? It is required in order to access RHEL for SAP HANA channel.

When I do "subscription-manager list --available" I see only one subscription called "Red Hat Satellite - Add-Ons for Providers". This subscription says, under the Provides section, "RHEL for SAP HANA - Extended Update Support", "Red Hat Enterprise Linux for SAP" among other things. Also, I can attach to this subscription pool.

Does this mean that I have the RHEL for SAP HANA subscription?

hello, I'm trying to add the sap hana subscription using the command below subscription-manager repos --enable="rhel-sap-hana-for-rhel-7-server-rpms" --enable="rhel-7-server-rpms" Error: 'rhel-sap-hana-for-rhel-7-server-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories. can you help me?

Hello, I'm trying to install repo list for id - "rhel-sap-hana-for-rhel-7-server-e4s-rpms" (using article - https://access.redhat.com/solutions/3075991) but getting following error message - https://cdn.redhat.com/content/e4s/rhel/server/7/7.2/x86_64/sap-hana/os/repodata/respond.xml: [Errno 14] HTTPS Error 404 - Not Found

Repo id - "rhel-sap-hana-for-rhel-7-server-e4s-rpms" has content - "compat-sap-c++" which is required for installing S/4HANA, please help if anyone can provide any inputs on the same.