How to recover from a Kernel Panic -not syncing

Latest response

Just got a" Kernel Panic -not syncing : attempted to kill init" error after I switch my selinux in enforcing mode and rebooted.
~~~
Kernel Panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-573.22.1.el6.x86_64 #1
Call Trace:
[] ? panic+0xa7/0x16f
[] ? do_exit+0x867/0x870
[] ? fput+0x25/0x30
[] ? do_group_exit+0x50/0xd0
[] ? sys_exit_group+0x17/0x20
[] ? system_call_fastpath+0x16/0x1b
drm_kms_helper: panic occurred, switching back to text console
~~~
I have -573.22.1
-573.3.1
-573.1.1
-504.30.3
I tried to boot back with other old versions, but none of worked and all have "Kernel Panic", so I could not to run the sosreport from old version either. How can I recover from this?

Responses

OK. I can boot again after using the RHEL7.1 installation disk and then went through the rescue procedures. Using the online text mode, I edited my original selinx of the local image under the /mnt/sysimage. Saved it and reboot it. Now I can booted back into my RHEL 6.7. However, I have no idea whether the Kernel Panic was fixed or not.

This issue can be caused due to issue on selinux policy configured on /etc/selinux/config

  1. Boot on rescue mode and update selinux config file as follows: SELINUX=disabled SELINUXTYPE=targeted

  2. Reboot the system

  3. After the successful boot you can re-enable selinux

I am having the same error with my rhel 6.4 on Oracle Virtualbox 6.0. I am still stuck on this. Please help. I was trying to configure the prerequisite setting for Oracle 12c, and i disabled selinux, did some update to the server, etc. I rebooted so that i can continue the configuration but I was prevented by kernel panic.

Olumide, just as a thought, boot into the previous kernel. Oracle kernel modules "ought to" be loaded automagically upon a new kernel upgrade with rhel 6.x (side note, you ought to upgrade to RHEL 6.10, we have oracle servers at 6.10 still with one customer).

If you reboot successfully to the previous kernel, it might be the kernel module. (are you using Oracle ASM??) https://access.redhat.com/discussions/1136813 and https://access.redhat.com/solutions/47753 and not answered https://community.oracle.com/thread/3518636

Regards

RJ

Thank you for your response. No, i am not using Oracle ASM. I have RHEL 6 and Oracle database 12c downloaded. I have installed rhel 6 on Oracle virtualbox successfully. I have deleted the initial installation and stated refreshed but still got stuck with the same problem. After an update and reboot, the system stuck "Kernel panic - not syncing: Attempted to kill init! Pid: 1, comm: switch_root Not tainted 2.6.32-431.el6.x86_64 #1" some post said that it have to do with glibc. rpm -q glibc-common output in rescue mode is "glibc-common-2.12-1.212-el6.x86_64" Now, i am stuck at same point again.

Olumide,

If you are getting glibc issues, this could be something else entirely. It somewhat sounds like you're experiencing ... rpm or yum issues. Are you directly connected to red hat for updates? or do you use a satellite server?

It's .... odd you have the same issue after reinstalling.... Are you able to revert to a previous kernel at grub?

RJ

Thank Hinton. I am getting the update from Redhat server ( yum install update) after registering the software. I just love to be able crack this issue should in case it occur next time. Right now, i want to download another version of Redhat to be able to continue with my oracle installation.

Olumide, I'd recommend using RHEL version 7.6 (the latest as I type this today) if you're going to install a new version of Oracle on a fresh version of Red Hat Linux

Regards

RJ

Hi All, recently i pached my RHEL5 server , after reboot i am getting kernel panic error, i tried to reboot with previous kernel, but in previous kernel also i am getting same issue, can any one tell me what is the issue

Hi Gangadhar Jena,

Have you tried to boot from a RHEL 5.11 DVD (iso) using rescue mode to run the sosreport? * chroot /mnt/sysimage * sosreport -vvvv

I advise you to run fsck on your filesystems too when in rescue mode.

  • df -h
  • fsck _/dev/found in df output_

reinstall the latest kernel

  • yum reinstall _latest kernel_ -y

Is the system running selinux? If so run

  • touch /.autorelabel

and try to boot again.

Regards,

Jan Gerrit Kootstra