yum fails with error "[Errno 14] HTTPS Error 403 - Forbidden" on Red Hat Enterprise Linux 7.

Latest response

Hi,
I installed Rehd Hat Enterprise Linux 7 free trial on virtual box. I want to install openstack-packstack . I follow the manual step by step.
Getting the below issue while running the "yum install openstack-packstack" and any use of yum. Any one can suggest to get out of this issue?I would be appriciate.

[root@localhost ~]# yum install openstack-packstack
Loaded plugins: product-id, subscription-manager
https://cdn.redhat.com/content/dist/rhel/server/7/7.0-1.el7/x86_64/openstack/7.0/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.


 One of the configured repositories failed (Red Hat OpenStack 7.0 for RHEL 7 (RPMs)),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable rhel-7-server-openstack-7.0-rpms

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=rhel-7-server-openstack-7.0-rpms.skip_if_unavailable=true

failure: repodata/repomd.xml from rhel-7-server-openstack-7.0-rpms: [Errno 256] No more mirrors to try.
https://cdn.redhat.com/content/dist/rhel/server/7/7.0-1.el7/x86_64/openstack/7.0/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

Responses

Is this problem fixed, or still doing anything? It's really really time-consuming.

I'm having the same problem. Are there any updates on this?

I am also having the same problem I need help

Same problem today

Looks a bit like a registration/subscription issue. Try the folllwing:

  • Check that the right subscription is attached:
# subscription-manager status
  • Refresh your subscription details:
# subscription-manager refresh
  • Check that the repo appears:
# subscription-manager repos --list-enabled
  • Try reinstalling:
# yum install openstack-packstack
  • If that still doesn't work, try reregistering the system:
# subscription-manager unregister
# subscription-manager register
etc
etc

I was getting similar issue, ' subscription-manager refresh' worked for me

Anyone landing here - consider what Rudra Pratap Singh said above, however, please note, this discussion was started in 2015. Occasionally people will post in here again.

There are occasions where Red Hat will have a temporary outage, or one must take additional actions not listed in this discussion. Consider a ticket with Red Hat as well so that way they can examine if there is something on their end (such as a repository CDN that temporarily has an issue).

Please keep the dates in mind of the posts above when you land here.

Kind Regards,
RJ