UEFI Kickstart failed to find a suitable stage1 device

Latest response

Here is the error:
Starting installer, one moment...
anaconda 19.31.123-1 for Red Hat Enterprise Linux 7.1 started.
* installation log files are stored in /tmp during the installation
* shell is available on TTY2
* when reporting a bug add logs from /tmp as separate text/plain attachments
14:37:57 Not asking for VNC because of an automated install
14:37:57 Not asking for VNC because we don't have a network
Starting automated install.............
Generating updated storage configuration
storage configuration failed: failed to find a suitable stage1 device

I used the Kickstart (KS) configurator to make sure I was not making some basic error but I get the same result.
If I follow the installation through after manually specifying additional items, including disk install destination, I am able to install RH.
When the system reboots and I can login, none of my custom packages are loaded so I assume whatever the error is that it terminates my KS.

Here is the auto generated KS file.
lang en_US
keyboard us
timezone America/New_York --isUtc
rootpw ### --iscrypted

platform x86, AMD64, or Intel EM64T

reboot
text
bootloader --location=partition --append="rhgb quiet crashkernel=auto"
zerombr
clearpart --all --initlabel
autopart
network --device=eno1 --bootproto=static --ip=192.168.3.1 --netmask=255.255.0.0
network --device=eno2 --bootproto=static --ip=192.168.3.2 --netmask=255.255.0.0
network --device=eno3 --bootproto=static --ip=192.168.3.3 --netmask=255.255.0.0
network --device=eno4 --bootproto=static --ip=192.168.3.4 --netmask=255.255.0.0
auth --passalgo=sha512 --useshadow
selinux --disabled
firewall --disabled
skipx
firstboot --disable
%packages
@debugging
@perl-runtime
perl-DateTime-Locale
perl-DateTime-Format-DateParse
perl-Date-Calc
perl-DateTime-TimeZone
perl-DateTime
@hardware-monitoring
@performance
@console-internet
@legacy-unix
@large-systems
@network-tools
@base
%end

Here is what I get after the error (note the missing parameters):
Installation

Exception yum.Errors.RepoError: RepoError() in > ignored

1) [!] Timezone settings 2) [x] Language settings
(Timezone is not set.) (English (United States))
3) [!] Software selection 4) [!] Installation source
(Minimal Install) (Local media)
5) [x] Network settings 6) [!] Install Destination
(Not connected) (Kickstart insufficient)
7) [x] Kdump 8) [!] Set root password
(Kdump is enabled) (Password is not set.)
9) [!] Create user
(No user will be created)
Not enough space in file systems for the current software selection. An additional 2861.02 MiB is needed.
Please make your choice from above ['q' to quit | 'b' to begin installation |
'r' to refresh]:

Any help would be appreciated.

Responses

Any help would be appreciated.

I've got the same error when the /boot/efi partition was missing in the partitioning scheme. Try to add it to your storage configuration. Something like (use your own device, of course):
part /boot/efi --fstype vfat --size=200 --ondisk=sda

The installer should create it as the fist partition.

Oh, looks like the input field filtered out out my example in sharp brackets. Put your disk to the --ondisk=, like
part /boot/efi --fstype vfat --size=200 --ondisk=sda