SNMP not working properly. Timeout: No Response from localhost

Latest response

Hi,

We are facing some typical issue with SNMP. we are running the below "snmpwalk" command. but sometimes it is running and sometimes it is getting Timeout error.
"snmpwalk -v 1 -c public localhost system"
We have tried the latest nety-snmp rpms.

our snmpd.conf file is very simple.
cat /etc/snmp/snmpd.conf
rocommunity public
rwcommunity public

can anyone please help in troubleshooting the issue?

Thanks & Regards,
Sanjay

Sanjay Batra's picture

Responses

Couple of things that can cause this:
* You don't have an appropriate ALLOW rule in /etc/hosts.allow
* You don't have an appropriate exception in your iptables configuration.

...and you probably want your snmpd.conf to be a skosh more complex than what you've listed:

In each case, only one directive should be specified for a given SNMPv3 user, or community string. It is not appropriate to specify
both rouser and rwuser directives referring to the same SNMPv3 user (or equivalent community settings). The rwuser directive
provides all the access of rouser (as well as allowing SET support). The same holds true for the community-based directives.

That is, you'd want your community-strings for your rocommunity and rwcommunity settings to be different.

Hi Tom,

Thanks for you reply. we have already tried the /etc/hosts.allow but no luck. we have disabled the iptables also. We also played with route table but there is no luck at all.

we do not want to use SNMPv3, we will be working on SNMPv1 onlly. so we are using the simple snmpd.conf file. even we have tried with different snmpd.conf configurations. but we are unsuccessful.

Other one thing we observed from debugging the snmpd process and doing strace on snmpwalk process.
1. snmpd process is keep on polling all the network interfaces on that server.
2.snmpwalk sending the sendmsg call 5 times and its getting timedout.
3. if my snmpwalk request is sending the sendmsg calls immediatly after all network interfaces polling of snmpd process. i will get the MIB's output.

is it normal behavior of SNMP on redhat or something unusual here?

Please help us, we facing this issue from more than 2 weeks. if you want any other info.details please let us know.

Thanks & Regards,
Sanjay.

Have you confirmed that the snmp daemon is listening on the 'lo' interface? it may have only bound to eth0.

Running the following should answer the question.

netstat -lnp

Also try attempting to connect to the host on the eth0 IP address rather than using the loopback interface.

We were able to resolve the issue by updating the network driver for the intel NIC to the latest available network driver. Hope this helps.

Thanks,
Sanjay

Hello
I have a virtual machine with RHEL5.2 and E1000 nic driver model running on host with ESXi5.5U2.
snmpwalk -v 2c -c community go in timeout
iptables is of and service stopped
snmpd.conf contains rocommunity
networking works ok with other machines on the network.

what other I can do ?
thanks
GB

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.