Unable to update glibc in RedHat 5.1

Latest response

Hello,

I'm unable to get any update or install going in my server.
I have opened a previous discussion where I was asked if I have an active subscription which I do.

Again, This is what I have

ls /etc/yum.repos.d/
rhel-debuginfo.repo

when I run yum update glibc, the following output is displayed :

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
No Repositories Available to Set Up
Reading repository metadata in from local files Could not find update match for glibc No Packages marked for Update/Obsoletion

I don't know if I'm doing this right but even if I try to install epel-release it doesn't give me any packages available..

Thank you

Responses

Hi,

This part is interesting: Loading "installonlyn" plugin. That doesn't look familiar, and the list of plugins certainly looks incomplete.

What plugins do you have in /usr/lib/yum-plugins/? You should have /usr/lib/yum-plugins/rhnplugin.py, and it must be enabled in /etc/yum/pluginconf.d/rhnplugin.conf. Alternatively, you could use Subscription Manager instead of RHN. It has another plugin and configuration file.

Radek

Hi Kwala,

Is your server registered to Red Hat Network or a Red Hat (Network) Satellite?
In other words, did you run rhn_register on this server?

If not: What may be the cause.

Be aware patching glibc and nscd for the GHOST vulnerabilty will introduction a RHEL 5.11 patch.

Kind regards,

Jan Gerrit

The output of yum would be different if the system just weren't registered. Specifically:

yum update

Loaded plugins: rhnplugin
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
Setting up Update Process
No Packages marked for Update

Hello,

i tried getting the rhnplugin from a similar server but i got this error when retrying the update:
Error: failed to retrieve getPackage/glibc-2.5-123.el5_11.1.x86_64.rpm from rhel-x86_64-server-5
error was [Errno -1] Header is not complete.
where can i get this missing plugin ?

Thank you

Hi,

It seems the plugin is working -- you have the rhel-x86_64-server-5 repo now, which is good.

The error message can have several reasons, but you might make things work by cleaning yum's cache (yum clean all); then try again. If yum still fails, try increasing the debug level: yum -d 10 update...

hello,
i keep getting the same error about the incomplete header, so maybe the plugin that i added is not compatible with this distribution.

Where did you get the plugin from? Your subscription should allow you to log in the RHN web UI and download any binary package for your system.

Another thing that might "upset" yum is a network issue, e.g. proxy configuration.

I tried to search for the missing plugin via our RHN subscription but no results found.
Can you plz provide me with a link from which i can get this plugin
No there is no proxy configured.
thank you

https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=789965 (I hope this ID works for you.)

This is yum-rhn-plugin-0.5.4.1-7.el5, which is the latest released version for RHEL 5 (5.11). Note: it requires rhn-client-tools >= 0.4.20.1-4, but if you're really running 5.1, you most likely have rhn-client-tools-0.4.16-1.el5, in which case you might want yum-rhn-plugin-0.5.2-3.el5, available from https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=422022.

Hello
Thanks for the link, the rhn-plugin was successfully installed. But now when i try to update glibc i get new errors:

yum update glibc
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-x86_64-server-vt-5 100% |=========================| 1.4 kB 00:00
rhel-x86_64-server-5 100% |=========================| 1.4 kB 00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for glibc to pack into transaction set.
glibc-2.5-123.el5_11.1.x8 100% |=========================| 601 B 00:00
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 143, in main
(result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.4/site-packages/yum/init.py", line 441, in buildTra nsaction
(rescode, restring) = self.resolveDeps()
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 194, in resolveD eps
self.populateTs(test=1)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populate Ts
self.downloadHeader(txmbr.po)
File "/usr/lib/python2.4/site-packages/yum/init.py", line 760, in download Header
cache=repo.http_caching != 'none',
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 461, in getHeader
cache=cache,
File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
start, end, copy_local, checkfunc, text, reget, cache)
File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
return result
UnboundLocalError: local variable 'result' referenced before assignment

Thank you for your help

Hi,

That looks like https://bugzilla.redhat.com/show_bug.cgi?id=378911#c72 . And I think you'll really need the new rhn-client-tools, too, because the package contains a new certificate. Try this, though:

grep Not\ After /usr/share/rhn/RHNS-CA-CERT