Satellite 6 katello-installer elasticsearch fails to start

Latest response

I am attempting to perform a fresh install of Satellite 6 on a RHEL 6.6 system following the instructions provided at Red Hat Satellite Installation

I began the install using the subscription-manager, so far so good at this point. Then I move on to Configuring Red Hat Satellite Manually

I run the katello-installer and I am hanging-up on the step where it attempts to start elasticsearch. I receive this error on STDERR:

Could not start Service[elasticsearch]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait elasticsearch start' returned 5: Starting elasticsearch: [  OK  ]
 /Stage[main]/Elasticsearch::Service/Service[elasticsearch]/ensure: change from stopped to running failed: Could not start Service[elasticsearch]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait elasticsearch start' returned 5: Starting elasticsearch: [  OK  ]
 /Stage[main]/Elasticsearch::Service/Service[elasticsearch]: Failed to call refresh: Could not restart Service[elasticsearch]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait elasticsearch restart' returned 5: Stopping elasticsearch: [  OK  ]
 /Stage[main]/Elasticsearch::Service/Service[elasticsearch]: Could not restart Service[elasticsearch]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait elasticsearch restart' returned 5: Stopping elasticsearch: [  OK  ]

I am attaching the log snippet from /var/log/katello-installer/katello-installer.log that contains the elasticsearch errors.

Doing some initial digging around I found this Knowledgebase article: katello-installer fails starting elasticsearch and tomcat6 if IPv6 is not configured properly I disabled IPv6 on the system prior to running the katello-installer using Red Hat's documentation. I ran through the suggestions in this article, just to make sure I didn't miss anything. However I'm still getting the same elastic search start-up errors.

I haven't been able to find any additional references regarding this problem.

Any advice/assistance you have would be great.

Thank you.

Attachments

Responses

In this case Elasticsearch is starting properly, we are just not able to detect it based on the wget and curl commands we run as part of the service restart.

You can test the connectiviity by running:

/usr/bin/wget --timeout=1 -4 --tries=5 --retry-connrefused --no-check-certificate http://localhost:9200

and looking for errors.

There are a couple of possible issues that are known that could cause it:

a) Do you have either of these proxy environmental variables defined: http_proxy or https_proxy?

You'll want to unset those prior to running the installer

See: https://bugzilla.redhat.com/show_bug.cgi?id=1156516

b) Did you follow the install guide (section 2.2 step 5) and setup uuid specific iptables rules?

(if so, there is a bug in the documentation)

See: https://bugzilla.redhat.com/show_bug.cgi?id=1161254

Justin - I removed the iptables OUTPUT chain rules pertaining to foreman and katello on port 9200. I am now able to get further along.

However, I'm getting what looks to be the same behavior for mongod. It's starting up, but possibly due to firewall constraints the installer is unable to verify?

The /var/lib/mongodb/mongodb.log shows no errors and that it is running accepting connections on port 27017 and the admin web console waiting for connections on port 28017. There were no instructions in the documentation saying these ports need to be open.

Are you aware of any issues with this?

Thank you for your help.

After removing the OUTPUT chain iptables rules reported in the documentation bug and added in rules to allow mongodb's ports (27017 and 28017) the installer completed successfully. I am now able to reach the web admin console and log-in.

Should the mongodb ports also be added to the documentation?

I also removed the firewall rules to permit the install to run.