Unable to get higher resolution 800x600 & monitor doesn't detected

Latest response

I am not able to get higher resolution in RHEL 6 (santigo) i.e. 800x600. apart from this monitor is also not detected.

below I have provided necessary details.

[root]#cat /etc/release
[root]#RHEL server release 6.0 (Santiago)

[root]#uname –mrs
[root]#Linux 2.6.32-72.el6.i686

Note- RHEL 6.0 doesn't create any Xorg.conf file. So, there is no such file /X11/Xorg.conf file at this location.

My main concern is to get other resolution which I have mention below in GUI mode.

Modes "1280x1024" "1280x800" "1024x768" "1024x800" "800x600" "640x480"

further additional information.

[root@localhost Desktop]# lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0166] (rev 09) (prog-if 00 [VGA controller])
Subsystem: Intel Corporation Device [8086:2111]
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at [disabled]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features
00:14.0 USB Controller [0c03]: Intel Corporation Device [8086:1e31] (rev 04) (prog-if 30)
Subsystem: Intel Corporation Device [8086:1e31]

root@localhost Desktop]# xrandr
Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
800x600 61.0*
640x480 60.0

Responses

We had a similar issue when we were using a digital KVM device (keyboard video mouse interface). Are you using a digital KVM? When we disconnected our digital KVM during the build, it worked fine. Your mileage may vary.

Hope this helps... come back and someone will likely chime in if not.

Great...It works..Could you please suggest any permanent solution.

Hi Rakesh Rena,

This discussion you found was originally posted in 2014, and later updated in 2016. I'm glad you specific issue is resolved in 2019. Let us know if you need assistance.

Regards

RJ

No, I am not using any KVM. its a AAEON display monitor.

Sushil,

Just curious, who manufactured the system? Is the display output connector on the motherboard itself, or is there some sort of Intel graphics card installed? From the details you have above, it would seem to be a generic Intel based vga display.

There are some rare cases where the Operating system and CLI commands will not pick up the graphics card, it is rare.

LINK UPDATED 11/12/2014, Thank you Akemi Yagi
If (if) it is an intel-based video driver, perhaps evaluate trying "elrepo", not a guarantee, but perhaps elrepo repositories might have what you need, on the condition your driver is really Intel-based and that repo matches what your system needs.

Also see this discussion.

Hope this helps...

See from VGA port we have connected to display monitor. [VGA port is on board]. I will try your shared link and update you.

any other solution do you have ?

Hi,

additional details-

[root@localhost Desktop]# xrandr
Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
800x600 0.0*
640x480 0.0

  1. -> cat /etc/release
    Ans->RHEL server release 6.0 (Santiago)
  2. -> uname –mrs
    Ans->Linux 2.6.32-72.el6.i686

when I give "Xorg :1 -configure" it gets crashed.

below is the output.


////////////////////////////////////////out put of "Xorg :1-configure"//////////////////////////////////////////////////////////// [root@localhost Desktop]# Xorg :1 -configure X.Org X Server 1.7.7 Release Date: 2010-05-04 X Protocol Version 11, Revision 0 Build Operating System: x86-009 2.6.18-194.8.1.el5 Current Operating System: Linux localhost.localdomain 2.6.32-71.el6.i686 #1 SMP Wed Sep 1 01:26:34 EDT 2010 i686 Kernel command line: ro root=UUID=50f0296a-1aab-49fc-9ef0-0225ad1e4c1e rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M@0M rhgb quiet Build Date: 11 August 2010 11:52:27AM Build ID: xorg-x11-server 1.7.7-26.el6 Current version of pixman: 0.16.6 Before reporting problems, check https://www.redhat.com/apps/support/ to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.1.log", Time: Sat Jul 21 10:59:56 2012 List of video drivers: glint ztv nouveau siliconmotion savage mga apm sisusb openchrome r128 qxl rendition amd v4l trident nv tdfx i128 intel sis ati s3virge geode ast i740 neomagic vmware cirrus radeon mach64 voodoo dummy fbdev vesa (++) Using config file: "/root/xorg.conf.new" (EE) open /dev/fb0: No such device Backtrace: 0: Xorg (xorg_backtrace+0x3c) [0x80b33ac] 1: Xorg (0x8048000+0x59596) [0x80a1596] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xcff40c] Segmentation fault at address (nil) Fatal server error: Caught signal 11 (Segmentation fault). Server aborting Please consult the Red Hat, Inc. support at https://www.redhat.com/apps/support/ for help. Please also check the log file at "/var/log/Xorg.1.log" for additional information. Aborted (core dumped) ///////////////////////////////////////////////End of Error////////////////////////////////////////////////////////////////////

But it create a file "xorg.conf"


file output- ****************************************************************************************************************** Section "ServerLayout" Identifier "X.org Configured" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection Section "Files" ModulePath "/usr/lib/xorg/modules" FontPath "catalogue:/etc/X11/fontpath.d" FontPath "built-ins" EndSection Section "Module" Load "record" Load "dbe" Load "dri" Load "glx" Load "dri2" Load "extmod" EndSection Section "InputDevice" Identifier "Keyboard0" Driver "kbd" EndSection Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/input/mice" Option "ZAxisMapping" "4 5 6 7" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Monitor Vendor" ModelName "Monitor Model" EndSection Section "Device" ### Available Driver options are:- ### Values: <i>: integer, <f>: float, <bool>: "True"/"False", ### <string>: "String", <freq>: "<f> Hz/kHz/MHz" ### [arg]: arg optional #Option "ShadowFB" # [<bool>] #Option "Rotate" # <str> #Option "fbdev" # <str> #Option "debug" # [<bool>] Identifier "Card0" Driver "fbdev" VendorName "Intel Corporation" BoardName "Unknown Board" BusID "PCI:0:2:0" EndSection Section "Screen" Identifier "Screen0" Device "Card0" Monitor "Monitor0" SubSection "Display" Viewport 0 0 Depth 1 EndSubSection SubSection "Display" Viewport 0 0 Depth 4 EndSubSection SubSection "Display" Viewport 0 0 Depth 8 EndSubSection SubSection "Display" Viewport 0 0 Depth 15 EndSubSection SubSection "Display" Viewport 0 0 Depth 16 EndSubSection SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection ******************************************************************************************************************

in above xorg.conf file,I have updated the section monitor and sub section Display ,by taking those value from fedora xorg.conf file.

but during next boot up it stuck after “starting UP CIM server [ok]”.

How to proceed further.

I tried another way also.


[root@localhost Desktop]# cvt 1024 768 # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz Modeline "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync [root@localhost Desktop]# xrandr --newmode "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync [root@localhost Desktop]# xrandr --addmode default 1024x768_60.00 [failed to move crt] [root@localhost Desktop]# xrandr --output default --mode 1024x768_60.00 xrandr: Configure crtc 0 failed

but failed to change the display.

Hi Sushil, apologies, I've been at class this week, it's consuming my time. I'm hoping someone from the community can give you additional help,

Kind Regards,

hi Remmele,

its Ok.

--

Thanks & Regards,

This looks very similar to an issue I encountered on a fedora desktop. I tried the same methods you did, but wasn't successful. Ultimately a software update resolved the issue.

Hi David,

did you updated the kernel ?

Can provide details information on this.

Hi Sushil,

Formatting tip: By the way, when posting your code, remember to wrap the code with three tildes. (click on "Formatting Help under any post you make) See this link for formatting info
~~~
# Linux commands go here without expanding to gigantic text
~~~

# this is an example of code surrounded by three tilde characters above and below

Back to the discussion...
- I noticed from your post on November 5 2014 at 4:47 AM , you cited "vmware" as one of the drivers in your "List of video drivers".

  • Is this system physical or virtual? I suspect it's physical, but if it happens to be vmware, then do install vmware tools
  • If it is a physical system, are you able to:
    1) Download the intel device driver for your specific system
    2) Try the "El Repo" link I provided earlier in this discussion? (Namely, the post from October 30 2014 at 11:31 AM)

hi,

thanks but next time I will take care on format.

I am not using any virtual system. this is EOL product so i dont have much info on that.

I have once question why "root#Xorg :1 -configure" command is giving error segment fault .

Hi Sushil,

Regarding the segment fault, address that separately with Red Hat support.

From your original post, it seems you have an intel driver
- Quote from your text

root@localhost Desktop]# lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0166] (rev 09) (prog-if 00 [VGA controller])
Subsystem: Intel Corporation Device [8086:2111]
< output truncated, see original post you made > 
  • Have you determined if there is a intel device driver for your specific system, and downloaded/installed it?
  • If there is no driver provided by Intel for your Linux system, can you examine the the "El Repo" link I provided earlier in this discussion for an intel device driver? (Namely, the post from October 30 2014 at 11:31 AM)

consolidated above, deleted...

hi,

Elrepo link is giving error "404"

and there is no driver from supplier and intel.

Sorry about that, I typo'd it and fixed it, Thanks Akemi too

Sushil,

That link is broken. Here it is for the xorg-x11-drv-intel driver.

Thanks Akemi - appreciate that update, I also fixed my link for future people reading this discussion...

Hi Akemi,

got that link and "xorg-x11-drv-intel-2.99.911-6.el6.i686.rpm" I got this rpm from RHEL 6.6 .

tomorrow I will update xorg-x11-drv-intel driver rpm as mention above and try Xorg and xrandr command.

Hi Sushil,

The current version is xorg-x11-drv-intel-2.99.916-1.el6.elrepo and this is the one that is compatible with RHEL 6.6. Older versions will not work under 6.6. The announcement can be found on the ELRepo's mailing list.

Sushil,

Just for reference...

That link leading to El Repo also cites this Intel Open Source page for drivers for Linux https://01.org/linuxgraphics/. That page has a link leading to this intel installer for linux but it cites Fedora Linux and not RHEL. That being said, I've seen where some fedora RPMs still work for RHEL.

Even if you do not use the RPMs from the https://01.org/linuxgraphics/ website, it may be good for reference.

Has anyone solved this? I too am trying to achieve a resolution greater than 800x600. I also have Intel Graphics Generation 3 Rev 9. I am unable to install proper driver for RHEL 7.1 or 7.2. Dowloaded Intel Graphics Installer for Linux (based off of Fedora 19) - installer application installs OK but when I try to run, I receive "Distribution not supported". I am not sure how to trick the installer into really installing the driver. Searched all over web but not many are talking about intel graphics and RHEL support. Any help would be appreciated. Had to install RHEL under troubleshoot with basic graphics just to get the operating system installed. I know this is a driver issue...but how do I go about resolving it?

NOTE: anyone landing here - this specific discussion thread was started in 2014 and one additional comment in 2016. It was resurrected again in 2019. Just keep in mind that some of this is dated.

Regards RJ