RHEL 6.6 - How to install Samba 3 ?

Latest response

Im trying to install Samba 3 in RHEL 6.6:
[root@redhat kim]# yum install samba* -y

[root@redhat kim]# rpm -qa| grep samba
samba-common-3.6.23-12.el6.x86_64
samba-client-3.6.23-12.el6.x86_64
samba-winbind-3.6.23-12.el6.x86_64
samba-winbind-clients-3.6.23-12.el6.x86_64

[root@redhat kim]# smbpasswd -a kim (ok)
[root@redhat kim]# nano /etc/samba/smb.conf (ok)

Then im trying to restart & autostart Samba services, eq.:
service smb restart
service nmb restart
chkconfig smb on
chkconfig nmb on

[root@redhat kim]# service smb restart
smb: ukendt tjeneste (unknown service)

?smb & nmb is unknown.. so Im missing something?

Regards Kim

Responses

Hi!

So, I just took a look at the documentation and it looks simple.

Chapter 4. Samba
  https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Managing_Confined_Services/chap-Managing_Confined_Services-Samba.html

I tried on my RHEL6.5 and it works just fine. What I can see, though, is that, when I ran "yum install samba" it actually installed the "samba' package and its dependencies, not "samba-common". You got that installed because you added the star (yum install samba*). Try running a simple "yum install samba", it should get you the right packages installed.

Well, Thanks for Your reply.

The strange part is that I used: "yum install samba" before using: "yum install samba*"
But running "yum install samba" one more time did work and samba services is running :)

Regards Kim