make install DVD from ISO file - RHEL 6.5 32 bit

Latest response

I am confused with all the conflicting documentation on the process of making a bootable installation disk for RHEL 6.5 32bit.
How is this done?
Is it necessary to add additional code beyond the ISO?
If so, what is it and where can I get it.

Please describe the process of creating the boot disk.
Thanks.

Responses

Hi Dee. I'm sure someone from our community will be able to help you out with this, but I'm concerned to hear you found 'conflicting documentation' on the topic. Can you point to any specific examples? I'd like to fix any problems we might have with our content.

Hello Dee,

In order to Burn the ISO to Disk:

Open an ISO burning application (all modern Linux variants, Mac OSX, and Windows 7 have a built in application).
Burn the ISO to the appropriate CD or DVD (do not just copy the ISO file to the disk).
To verify that burning completed successfully, boot off the new disk and run a media check.
If the media check passes, the disk can safely be used to install the operating system.

Please also see

https://access.redhat.com/solutions/29036 How to download an ISO from RHN and burn it on CD/DVD

For commandline solution in RHEL, please see https://access.redhat.com/solutions/4069

Well, on the Redhat site, several documents with links (after I did a search "Make bootable DVD from ISO") came up as 404 file not found, so I abandoned that. General searches I found several documents, but the sum of that is that a boot file of some sort needs to be added to the disk to make it bootable. I purchased the WinISO program and tried that. It burned a disk, but it was not recognized by my Redhat 9 PC as a valid media. Trying to boot from it, it skipped over the DVD and came up on the installed image. I then looked at WinISO and it had an option to add boot information, but no information on what it needed. I tried a couple freeware ISO burners and had the same results. I also used the right-click option on my Win 7 machine, but had the same result after burning the ISO with that method.
Where do I go from here?

Hello Dee,

From your description, it seems to me that you might have burned the DVD correctly, but you have not configured your system to boot from the DVD-ROM.

The Red Hat Enterprise Linux 6 Installation Guide contains a chapter on booting the installer, which describes the general steps you need to take to configure your system for booting from removable media instead of the hard drive.

Generally, you need to:

  1. Power on your system, and insert the DVD into the optical drive. (You don't need to wait for the system to boot now, you just need the optical drive's tray to open.)
  2. Turn your system off, and then turn it back on again so the boot sequence starts from the beginning.
  3. Enter your system's "boot menu". This is the menu where you can configure the boot order - that is, which device the system should read first when attempting to find a bootable system. The way to access this menu is not standardized, so I can't give you any specific information - but you should watch the system's display for a message telling you which key to press. Usually, the message is something like "Press F10 to select boot device".
    It is also possible that your system has boot order configuration inside the BIOS (SETUP) utility. In that case, access SETUP (usually by pressing Del at the beginning of the boot process, but again the exact key varies), find a menu entry that contains boot order configuration, and change the boot order so that the DVD-ROM is the first device in the list.
  4. If you successfully changed the boot order so that the system looks at the DVD first, you should be now able to boot the Red Hat Enterprise Linux installation DVD and get to the boot menu.

Petr, I am on board with your possible solution, however,
I am sure that I have complied with all those steps.
In the booting process it shows that it is attempting to
boot from CD/DVD device. After about 20 seconds it abandons that
and boots from the hard disk image.

After successful boot from disk image, I attempted to mount the
DVD and the report was "No media available to mount".

nitin,
I am currently downloading a new copy.
I have installed fciv and I will verify the MD5.
I will re-attempt to do the Win7 burn ISO to disc option.

Nitin Yewale,
I have downloaded a fresh copy of rhel-server-6.5-i386-dvd.iso.
I checked the MD5 with fciv.
Using the Win7 burn disc image on the right-click menu, I burned
and verified a new DVD.
I am driving the disc to the site to check it out.
I should be back in about an hour.

Hello Dee,

Thank you for the update. I assume here that you used the option something like, 'Burn image to disk' (correct option) and not 'copy data to disk' (incorrect option).

Let us know the result.

Thank you
Nitin

Nitin Yawale,
Unsuccessful run.
I did use the burn not the copy.
I tried it on two PCs in the lab.
They are both P4 3Ghz from 2004.
One is running old Redhat 9 which is 32 bit.
The other is running RHEL 5.9 32 bit.
The boot exercise produced the same results as before - failed to boot.
I have a n RHEL 5.9 32 bit installation disk which I re-tested. It boots
on both machines and enters anaconda.
The 5.9 disk was written on my WinXP machine before it was retired. I now
have Win 7 Machine (Dell OptiPlex 960).
Besides the Win7 burn option, my previous result also came up dead using
WinISO which I downloaded. I did not run it this time.
Do we need more information or testing?

Nitin,
I just had a thought.
The RHEL 5.9 disk is a CD not a DVD.
It may just be possible that the drive does not support DVD.
Looking into that now.
Thoughts???

OK, Nitin,

In an effort to bring this discussion to a close, I would like to report that I have
confirmed that the hardware I am trying to update does support only CDs. I have chosen to install the RHEL 5.9 CD installation package which should work just fine. This contract will not run long enough for the customer to complain that we are not on 6. I believe 5.9 is still supported for a while. Do you know for sure?
If I can't do that I will need to perform a hardware upgrade.
I will have to wait for a few days to take down one of our newer PCs so I can try the booting on a real DVD drive.
So, we can consider this discussion complete unless you have some comments or questions.
Thank you for your assistance on addressing this challenge.

Hello Dee,

Gald to know that RHEL 5.9 was installed.

Regarding the support for RHEL 5.9, the End of Phase 2 for RHEL 5 happened on January 31, 2014 and now it is in Production phase 3 where critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available. Other errata advisories may be delivered as appropriate.

New functionality and new hardware enablement are not planned for availability in the Production 3 Phase. Minor releases with updated installation images may be made available in this Phase.

For more details, please see https://access.redhat.com/support/policy/updates/errata/

Hope this helps.

Thank you
Nitin Yewale
Red Hat, Inc.
Supporting success. Exceeding expectations.

Thank you for your assistance and information.
I found the Phoenix BIOS on my PC supports USB CDROM, so I purchased a USB drive and started the installation of RHEL 6.5. The installation software advised there is not enough memory to support the installation. I will handle this - purchasing memory expansion and installation. I am sure I will be successful on this final phase of installation.

Hello Dee,

Make sure to review the Red Hat Enterprise Linux technology capabilities and limits article. It contains, among other things, a list of minimum system requirements for various versions of Red Hat Enterprise Linux.

For RHEL 6, the minimum amount of memory is 512 MB (for the 32-bit x86 architecture); the recommended amount is 1 GB for each logical CPU on the system.

Taking care of memory upgrade this AM. Putting 2Gb (2x1Gb) to take care of shortage. Thanks.

Hello - anyone landing here, please know this discussion was started and mostly ended in July of 2014.

Please highly consider using a much more current version of Red Hat Linux at this link

Kind Regards,
RJ