RHEL 7 under VMWare Workstation 10: Problem with Network

Latest response

I have installed RHEL 7 as minimal installation under VMWare Workstation 10.

I cannot configure any network devices. The kernel doesn't find any.

I have tried open-vmware-tools, which comes with RHEL7 and also tested the VMWare tools which come with VMWare Workstation 10.
No difference.

Does anybody have a hint for me?

Dirk

Responses

Hey Dirk - what does the following command return?

lspci | grep -i net
lsmod | egrep -i 'net|intel|e1000'
lspci -k -vv | grep -i net -A20

EDIT: the lspci -k will show you which driver is loaded for that device.

Dirk, James is most likely on to something here...

I had this issue with a vmware system recently, I had to make sure I used the e1000 network interface until I installed vmware tools and we could create another network interface for the other vmxnet3 (I think the name was).

When yo ugo through the vmwware graphical interface - click on "edit settings" and find/click on the network interface. What sort of interface does it show as? e1000?

Let us know, thanks

Is RHEL now coming with it's own "VMware Tools" for clients now? Or was that Fedora/CentOS that I noticed that? I think I'm getting old ;-)

I just notcied my RHEL 7 guest has an ens33 interface. huh? ;-)

RHEL 6 onwards ship with the GPL'd kernel modules which VMWare have contributed to the upstream Linux Kernel, so drivers like vmxnet3 or vmw_pvscsi are just like any driver supplied in the kernel package.

The complete VMware Tools suite (probably with later driver versions than RHEL has) is provided by VMWare.

Output of: lspci -k -vv | grep net:

02:01.0 Ethernet controller: Advanced Micro Devices, Inc. [AMD] 79c970 [PCnet32 LANCE] (rev 10)
Subsystem: Advanced Micro Devices, Inc. [AMD] PCnet - Fast 79C971
02:02.0 Ethernet controller: Advanced Micro Devices, Inc. [AMD] 79c970 [PCnet32 LANCE] (rev 10)
Subsystem: Advanced Micro Devices, Inc. [AMD] PCnet - Fast 79C971

I can't find a setting in VMWare Workstation 10.0.3, where I can choose type of NIC.
I can only choose between: Bridged, NAT, Host-Only and custom.

I have now changed nic-type manually by editing my ".vmx"-file

Now I have "eno16777736" and "eno33554960"
Can I change that to eth0 and eth1?

I will now try to configure some IP-Addresses...

Got Ip-Addresses by "dhclient".
NICs are working properly.

I had same case. My vm was originally created with 2xNICs, but only one was seen ind Red Hat 7.
- shutdown my vm
- in VM Settings, Remove second nic, and Apply
- in VM Settings, Add new second nic (Bridged), and Power ON
- ifconfig ; now I have eno16777736 and eno33554960
- cp /etc/sysconfig/network-scripts/ifcfg-eno16777736 /etc/sysconfig/network-scripts/ifcfg-eno33554960
- in ifcfg-eno33554960 file, set HWADDR as you see in VM Settings (MAC Address), NAME=eth1, IPADDR/PREFIX/GATEWAY
- service network restart, or reboot
et voila

edit your RHEL7 VMware virtual machine config file it can be opened using text editors and add e1000 configuration then save and it will work

can someone give a screenshot how to modify the vmx file?

Before making any modifications to the config file, unregister the VM and make sure to backup the original one. Then you have to modify the .vmx file you will find in the VM Folder with a text editor, scroll down to the ethernet adapter options, and make sure the one you can´t see is set to "e1000", for example in my case the line for the second vmnic should look like this: ethernet1.vnet = "e1000". Save changes and re-register the VM to Workstation (File --> Open ---> Choose the .vmx file we just modified from the VM folder). It worked for me, no need to disable NM or anything else, just make sure you configure it properly and document the right HWADD.

i personally don't recommend editing config file manually - it is error prone. vmware-tools should have nothing to do with the network?

The fix for me was enabling the NIC that the Workstation created called in my case (ENS33):

I performed the following https://youtu.be/ZQkMYWTx28o

I've done those various edit the vmname.vmx file and gotten it to work in the past. It broke when Rhel went to 8.4 for me as it did for many other people. Today I learned that vmwareWorkstation 16.2.3 lists rhel8 as the os type. my OS build was using vmware workstation 14 and later upgraded to 16.1 which still didn't support rhel8 officially. Well to fix all of your driver needs 1. shutdown your vm 2. go to vmsettings / select options tab at the top. 3. Set your virtual machine to Red Hat Enterprise Linux 8. (this will tell workstation to use the correct vmxnet3 driver under ethernet1.virtualDev = "vmxnet3" for all of the interfaces you will attach. 4. blow away your old attached network interface cards 5. hit ok allow. this will modify your vmx file accordingly. 6. go back into settings and add your 2 NIC's I use a NAT (i set up static routes to reach local vpn networks), and a Bridged (to bypass work VPN that hijacks my local nic.) 7. power up your vm, and wala your rhel8 box should be identifying and loading drivers for your rhel8 vm. 8. configure your nic's to your liking.