Problem with mounting CIFS subdirectories

Solution Verified - Updated -

Issue

  • CIFS sub-directories cannot be mounted.
  • It is possible to mount the main share and then switch to the sub-directory.
# mount -t cifs //server/share$ /mnt -o username=<user>,password=XXXXXXX
# cd /mnt ; cd "SPARE SHARE"
  • However, while mounting sub-directory directly if fails with an error "mount error 6 = No such device or address"
# mount  -t cifs //server/share$/SIG /mnt -o username=<user>,password=XXXXXXX
mount error 6 = No such device or address

Environment

  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 9
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 7
  • CIFS/SMB

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content