Unable to execute /usr/lib/cups/backend/smb: No such file or directory
Environment
- Red Hat Enterprise Linux (RHEL)
- Common Unix Printing System (CUPS)
- Samba
- Printing to a Windows print server
Issue
- After upgrading to Samba3x packages, smb printer is not working.
- I performed the upgrade of Samba and now I'm having an issue where I can't print to any of our SMB printers shared from Windows systems.
- There are three app nodes handling the printer requests. All three nodes are sending print jobs to a Windows server. I noticed that same printers got disabled on all three nodes.
Resolution
-
Check if
samba3x-clientorsamba-clientpackages are installed on the system:rpm -qa | grep samba* -
If the package is not installed, install as shown below, provided system is connected to Red Hat Network or Red Hat Satellite:
For RHEL 5:
yum install samba3x-clientFor RHEL 6 and 7:
yum install samba-client
Root Cause
Since samba-client (or samba3x-client) package was not installed, the file /usr/lib/cups/backend/smb was missing. The samba-client and samba3x-client packages provide /usr/lib/cups/backend/smb which is used to sent print jobs to Windows print servers.
The samba package does not need to be installed to send print jobs to a Windows print server. The samba package enables a Linux system to act as a SMB server, and to send print jobs, only the client software is required.
Diagnostic Steps
The CUPS log file /var/log/cups/error_log contains the following messages:
E [14/Dec/2015:13:36:16 -0500] Unable to execute /usr/lib/cups/backend/smb: No such file or directory
E [14/Dec/2015:13:36:16 -0500] [Job 106631] Stopping job because the sheduler could not execute the backend.
E [14/Dec/2015:13:36:16 -0500] Unable to execute /usr/lib/cups/backend/smb: No such file or directory
E [14/Dec/2015:13:36:16 -0500] [Job 106709] Stopping job because the sheduler could not execute the backend.
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.
Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.
