Unable to remove a VM via the RHEV Admin Portal if any disks are missing

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Virtualization (RHEV) 3.1

Issue

  • Unable to remove a VM via the RHEV Admin Portal.

  • A VM cannot be removed via the RHEV Admin Portal if any of its disks do not physically exist.

Resolution

Please contact Red Hat Technical Support for assistance with a VM that cannot be removed on RHEV 3.1.

Root Cause

  • In releases prior to RHEV 3.2 a VM cannot be removed via the Admin Portal if any of the underlying storage is missing.

  • Examples;

    • If a VM has three disks and two are missing from the storage domain, then the VM cannot be removed.

    • If a VM has one disk and a snapshot exists, but one of the volumes for these images does not physically exist in the storage domain, then the VM cannot be removed.

  • As of RHEV 3.2, VMs with missing disks can be removed via the RHEV Admin Portal.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments