yum fails with "Error: Package: package-version.el6.arch (custom-rhel-x86_64-server-6) Requires: libsnappy.so.1()(64bit)"

Solution Verified - Updated -


  • yum fails with following error
Error: Package: crash-6.1.0-5.el6.x86_64 (custom-rhel-x86_64-server-6)
           Requires: libsnappy.so.1()(64bit)
Error: Package: xorg-x11-drv-ati-7.1.0-3.el6.x86_64 (custom-rhel-x86_64-server-6)
           Requires: libglamor.so.0()(64bit)
Error: Package: kexec-tools-2.0.0-273.el6.x86_64 (custom-rhel-x86_64-server-6)
           Requires: libsnappy.so.1()(64bit)
Error: Package: 4:perl-devel-5.10.1-136.el6.x86_64 (custom-rhel-x86_64-server-6)
           Requires: gdbm-devel
Error: Package: ca-certificates-2013.1.95-65.1.el6_5.noarch (custom-rhel-x86_64-server-6)
           Requires: p11-kit-trust >= 0.18.4-2
Error: Package: ca-certificates-2013.1.95-65.1.el6_5.noarch (custom-rhel-x86_64-server-6)
           Requires: p11-kit >= 0.18.4-2


  • Red Hat Enterprise Linux (RHEL)
  • Red Hat Satellite

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content