Running rhevm-reports when Apache is not running fails

Solution Verified - Updated -

Issue

After upgrading from RHEV 3.2 to RHEV 3.3, running rhevm-reports-setup when Apache is not running fails:

[root@rhevm ~]# rhevm-reports-setup
Welcome to rhevm-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Backing up reports DB...                              [ DONE ]
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Backing up Installation...                            [ DONE ]
Updating DB Schema...                                 [ DONE ]
Exporting adhoc reports...                            [ DONE ]
Exporting scheduled reports...                        [ DONE ]
Exporting current users...                            [ DONE ]
Deploying Server...                                   [ DONE ]
Updating Redirect Servlet...                          [ DONE ]
Importing current users...                            [ DONE ]
Importing adhoc reports...                            [ DONE ]
Importing reports...                                  [ DONE ]
Importing current users...                            [ DONE ]
Customizing Server...                                 [ DONE ]
Importing scheduled reports...                        [ DONE ]
Restoring Installation...                             [ DONE ]
Restoring reports DB...                               [ DONE ]
Return Code is not zero
Error encountered while installing rhevm-reports, please consult the log file: /var/log/ovirt-engine/ovirt-engine-reports-setup-2014_02_27_05_09_27.log

Subsequent attempts to run rhevm-reports-setup also fail:

[root@rhevm ~]# rhevm-reports-setup
Welcome to rhevm-reports setup utility
Backing up reports DB...                              [ DONE ]
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Backing up Installation...                            [ DONE ]
Updating DB Schema...                                 [ ERROR ]
Return Code is not zero
Error encountered while installing rhevm-reports, please consult the log file: /var/log/ovirt-engine/ovirt-engine-reports-setup-2014_02_27_05_21_07.log

Environment

  • Red Hat Enterprise Virtualization (RHEV) 3.3
  • rhevm-reports-3.3.0-28.el6ev.noarch

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In