Can't deploy OpenShift Online application due to git push error "rsync: connection unexpectedly closed"

Solution Unverified - Updated -

Environment

  • Openshift Online Online

Issue

  • I've been having trouble with deploying my app, when I try to do a git push, I get the following error at the end of the deployment process:
    remote: Requirement already satisfied (use --upgrade to upgrade): wsgiref in /var/lib/openshift/11111111111111111111/app-root/runtime/dependencies/python/virtenv/lib/python2.6/site-packages (from selector==0.8.11->-r /var/lib/openshift/11111111111111111111/app-root/runtime/repo/hread/requirements/base.txt (line 3))
    remote: Requirement already satisfied (use --upgrade to upgrade): setuptools in /var/lib/openshift/11111111111111111111/app-root/runtime/dependencies/python/virtenv/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg (from django-threadedcomments==0.9->-r /var/lib/openshift/11111111111111111111/app-root/runtime/repo/thread/requirements/base.txt (line 52))
    remote: Cleaning up...
    remote: Preparing build for deployment
    remote: Deployment id is 14cede8e
    remote: Distributing deployment to child gears
    remote: Result: failure
    remote: Distribution status: failure
    remote: Distribution failed for the following gears:
    remote: 222222222222222222222222 (rsync: connection unexpectedly closed (0 bytes received so far) [sender])
    remote: 333333333333333333333333 (rsync: connection unexpectedly closed (0 bytes received so far) [sender])
    remote: Deployment completed with status: failure
    remote: postreceive failed
    To ssh://11111111111111111111@xyz.rhcloud.com/~/git/thread.git/
       03d7b16..60daeea  master -> master

Resolution

Please file a support case with Red Hat Global Support Services that the operations team check the application.

Root Cause

The problem appears to be that the public ssh key for the "head gear" of this app is not present in the authorized_keys files for the other web gears. The OpenShift Online operations team need to make a database change to fix this.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments