Ansible Automation Platform UI shows Internal Server Error when setting gateway_access_token_expiration to 0

Solution Verified - Updated -

Environment

  • Red Hat Ansible Automation Platform (Ansible Automation Platform) 2.5

Issue

  • Setting field Gateway access token expiration to 0 in platform settings causes Internal Server Error.

Resolution

To resolve the issue log in to automation gateway component and do the following:

  1. Execute the following query and check and confirm that raw_value is set to 0.

    echo "SELECT * FROM aap_gateway_api_preference WHERE name='gateway_access_token_expiration';" | aap-gateway-manage dbshell
    
  2. Execute the following query to change 0 value to higher value and clear the error.

    echo "UPDATE aap_gateway_api_preference SET raw_value = '600' WHERE name='gateway_access_token_expiration';" | aap-gateway-manage dbshell;
    
  3. Restart Gateway services.

    automation-gateway-service restart
    

Root Cause

This is a bug and reported to engineering team. It will be resolved in a future release of the product.

Diagnostic Steps

On the Ansible Automation Platform UI:

  1. Login to the Ansible Automation Platform's web UI.
  2. Go to the Settingssection.
  3. Under Platform Settings, set the value for Gateway access token expiration to 0.
  4. Save and logout.
  5. Log back in, and observe that the error is thrown.

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