'pcs resource move' command fails with error "Unable to move resource 'test_resource' using a location constraint. Current location of the resource may be affected by some other constraint".
Issue
pcs resource movecommand fails to move a cluster resource or resource group from one cluster node to the other node, when there is already one or more existingconstraint(s) in place for the same resource or resource group.
Environment
- Red Hat Enterprise Linux 9 and 10 with the High Availability Add On.
- Pacemaker
Subscriber exclusive content
A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.