noobaa-db-pg-0 Pod Fails to Start CrashLoopBackOff (CLBO) - "failed container=initialize-database" Wrong SCC
Issue
The noobaa-db-pg-0 pod fails to start because it does not have the permission to initialize the database due to picking up the wrong SCC.
state:
waiting:
message: back-off 1m20s restarting failed container=initialize-database pod=noobaa-db-pg-0_openshift-storage(4fdc3a96-48a7-4d35-ab3f-e3a35659f8bb)
reason: CrashLoopBackOff
phase: Pending
Environment
Red Hat OpenShift Container Platform (RHOCP) v4.x
Red Hat OpenShift Data Foundations (RHODF) v4.x
Red Hat OpenShift Container Storage (RHOCS) v4.x
Subscriber exclusive content
A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.