StatusCode=400 -- Original Error: Code="BadRequest" Message="The selected VM size 'Standard_NC24ads_A100_v4' cannot boot Hypervisor Generation '1'.

Solution Verified - Updated -

Environment

  • Azure Red Hat OpenShift (ARO)
    • 4.X

Issue

  • In the image session for the machineset YAMLconfiguration:
image:
  offer: aro4
  publisher: azureopenshift
  resourceID: ''
  sku: aro_410
  version: 410.84.20220125
  • Error in Azure side:
failure sending request for machine myworkernode: cannot create vm: compute.VirtualMachinesClient#CreateOrUpdate: Failure sending request: StatusCode=400 -- Original Error: Code="BadRequest" Message="The selected VM size 'Standard_NC24ads_A100_v4' cannot boot Hypervisor Generation '1'.

Resolution

Depending on the image used for the machine set, the value for image.sku and image.version must be set accordingly.

Example:

  • If using Standard_NC4as_T4_v3, it is supported both versions, as mentioned at Feature support. So no change is required.

  • If using Standard_NC24ads_A100_v4, only Generation 2 VM is supported.

In the case of Standard_NC24ads_A100_v4, the image.sku value must follow the equivalent v2 version of the cluster's original image.sku
For this example, the value will be v410-v2.

This can be found using below command:

az vm image list --architecture x64 -o table --all --offer aro4 --publisher azureopenshift
  • BEFORE
image:
  offer: aro4
  publisher: azureopenshift
  resourceID: ''
  sku: aro_410
  version: 410.84.20220125
  • AFTER
image:
  offer: aro4
  publisher: azureopenshift
  resourceID: ''
  sku: v410-v2
  version: 410.84.20220125

Root Cause

If the cluster was created with the base SKU aro_410. Azure reports that it cannot make the Standard_NC24ads_A100_v4 because this SKU requires a v2 hypervisor-compatible image. This is documented on Microsoft documentation for Virtual Machines , sessions: v2 and VM type: nc-a100-v4-series.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments