Quay.io login error e-mail address is already associated with an existing Quay account
Environment
- Red Hat Quay.io
Issue
-
Trying to login, but a warning message
Red Hat login errorwith the following text."The e-mail address `user@example.com` is already associated with an existing Quay account. Please log in with your username and password and associate your Red Hat account to use it in the future."
Resolution
The error message could be rectified through the implementation of the following steps:
- Please go to https://recovery.quay.io/signin
- Sign in with a existing Quay.io email address and password.
- Once in, open account settings, click on "External logins" on the left side, and then on the "Attach to Red Hat" link.
- Go to quay.io/signin and enter a Red Hat Customer Portal credentials and it should be set, Red Hat SSO button should work now.
Note: If needed try to Detach, open account settings, click on "External logins" on the left side, and then on the "Detach Account" and reattach when in recovery mode.
Root Cause
All accounts in Quay must have unique e-mail addresses and usernames. The issue here is that there exists a user under e-mail in Quay's db. Logging in with a user with the same e-mail address will not work because users are not connected via a special table in Quay's db and Quay will perceive logging in via that button as though a new user is coming in. Quay will then check if the e-mail address is unique and will find that it is not and will error out.
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