Dev Spaces shows "The gitlab integration is not configured properly" error when importing GIT repository

Solution Verified - Updated -

Issue

  • When trying to open a GIT repository in Dev Workspaces, this fails with the following error message being shown in the devspaces container:

    2023-02-08T12:18:29.876808209Z 2023-02-08 12:18:29,876[nio-8080-exec-1]  [ERROR] [c.a.c.r.RuntimeExceptionMapper 47]   - Internal Server Error occurred, error time: 2023-02-08 12:18:29
    2023-02-08T12:18:29.876808209Z java.lang.UnsupportedOperationException: The gitlab integration is not configured properly and cannot be used at this moment.Please refer to docs to check the Gitlab integration instructions
    2023-02-08T12:18:29.876808209Z  at org.eclipse.che.api.factory.server.gitlab.GitlabUrlParser.parse(GitlabUrlParser.java:137)
    [..]
    

Environment

  • Red Hat OpenShift Container Platform (OCP) 4.11
  • Dev Spaces Operator 3.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content