Upgrade to Satellite 6.12 fails on duplicate key value violates unique constraint "rpm_modulemd_name_stream_version_context_arch_f6598e4e_uniq"

Solution In Progress - Updated -

Issue

An upgrade of Satellite 6.11 -> 6.12 fails on django.db.utils.IntegrityError: duplicate key value violates unique constraint "rpm_modulemd_name_stream_version_context_arch_f6598e4e_uniq" error.

Environment

  • Red Hat Satellite 6.11
    • being upgraded to 6.12

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content