3scale Operator is using deprecated PodDisruptionBudget.v1beta1.policy API

Solution Verified - Updated -

Issue

  • It is observed that the 3scale operator (Red Hat Integration - 3scale) version 0.9.0 available for OCP 4.x (e.g. in OCP 4.10.x) is using deprecated API e.g. poddisruptionbudgets.v1beta1.policy, Ideally the PodDisruptionBudget should be using policy/v1 instead policy/v1beta1.

Environment

  • Red Hat 3scale API Management 2.12 On-Premises

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content