Pod fails with "The container could not be located when the pod was deleted. The container used to be Running" error

Solution Verified - Updated -

Issue

  • A pod is facing The container could not be located when the pod was deleted. The container used to be Running error.
  • The pod is stuck (it could be in Terminating or PodInitializing state) with below error:

        exitCode: 137
        finishedAt: null
        message: The container could not be located when the pod was deleted.  The
          container used to be Running
        reason: ContainerStatusUnknown
        startedAt: null
    

Environment

  • Red Hat OpenShift Container Platform (RHOCP)
    • 4

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content