Application plan change request on Developer Portal

Solution Verified - Updated -

Environment

  • Red Hat 3scale API Management
    • 2.X On-Premise
    • SaaS

Issue

  • When an application plan change is requested on the developer portal, there is no "Pending" state with "Accept" or "Reject" button in the Admin Portal.

Resolution

When a developer requests a plan change on the Developer portal, the plan change is completed via email and not through a "Accept" or "Reject" button. The following describes the process in more detail.

A developer initiates an application plan change using the following steps.

  1. Logs into into the developer portal and navigates to the APPLICATIONS tab.
  2. In the APPLICATIONS tab is list of applications the developer is subscribed to. In the form

    Name    Service    CREDENTIALS     STATE
    
  3. The service has multiple application plans for e.g. "Basic", "Unlimited" ,"Premium".

  4. Clicks on an application subscribed to a plan for service (e.g. "Basic"). The Edit window that pops up has the current plan a Review/Change button as shown below

    Plan  {current-plan}  > Review/Change
    
  5. Clicks on the Review/Change button to bring up all the available application plans for that service (e.g. "Basic", "Unlimited", "Premium")

  6. Selects the application plan to change to (e.g. "Unlimited"). This displays a "Request Plan Change" button.
  7. Clicks on the "Request Plan Change". This sends an email to the admin.

Admin receives the email changes the plan as follows

  1. Opens the email request contains the following information

    Details:
       Application: Testers's App
       Service: API
       Current plan: Basic
       Requested plan: Unlimited
    "Change Plan" ( URL to the application in the 3scale admin portal )
    

    The "Current plan" and "Requested plan" values shown are the ones used in this example.

  2. Clicks on the "Change Plan" URL, which navigates to the Application Details page in the the admin portal.
  3. There is no "Accept or Reject" option for changing the plan. However, in the right hand half, there is a section, "Change Plan" with a drop - down menu - Change applications plan
  4. Clicks on the the "Change Plan" Drop Down menu to display the other application plans available. (e.g. "Unlimited" , "Premuim").
  5. Selects the application plan to the "Requested plan" in the email. e.g. ("Unlimited") plan.
  6. When the application plan is selected, the greyed out "Change Plan" is highlighted.
  7. Clicks on "Change Plan".
  8. The application plan is changed (e.g. "Basic" to "Unlimited")

3scale sends an email notification to the developer that the application has been changed . The email is formatted using the "Application plan changed for buyer" email template.
Developer verifies the plan has been changed on the Developer Portal.

Root Cause

Changing a plan on the developer portal is not documented.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments