Application plan change request on Developer Portal
Environment
- Red Hat 3scale API Management
- 2.X On-Premise
- SaaS
Issue
- When an application plan change is requested on the developer portal, there is no "Pending" state with "Accept" or "Reject" button in the Admin Portal.
Resolution
When a developer requests a plan change on the Developer portal, the plan change is completed via email and not through a "Accept" or "Reject" button. The following describes the process in more detail.
A developer initiates an application plan change using the following steps.
- Logs into into the developer portal and navigates to the APPLICATIONS tab.
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In the APPLICATIONS tab is list of applications the developer is subscribed to. In the form
Name Service CREDENTIALS STATE
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The service has multiple application plans for e.g. "Basic", "Unlimited" ,"Premium".
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Clicks on an application subscribed to a plan for service (e.g. "Basic"). The Edit window that pops up has the current plan a Review/Change button as shown below
Plan {current-plan} > Review/Change
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Clicks on the Review/Change button to bring up all the available application plans for that service (e.g. "Basic", "Unlimited", "Premium")
- Selects the application plan to change to (e.g. "Unlimited"). This displays a "Request Plan Change" button.
- Clicks on the "Request Plan Change". This sends an email to the admin.
Admin receives the email changes the plan as follows
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Opens the email request contains the following information
Details: Application: Testers's App Service: API Current plan: Basic Requested plan: Unlimited "Change Plan" ( URL to the application in the 3scale admin portal )
The "Current plan" and "Requested plan" values shown are the ones used in this example.
- Clicks on the "Change Plan" URL, which navigates to the Application Details page in the the admin portal.
- There is no "Accept or Reject" option for changing the plan. However, in the right hand half, there is a section, "Change Plan" with a drop - down menu - Change applications plan
- Clicks on the the "Change Plan" Drop Down menu to display the other application plans available. (e.g. "Unlimited" , "Premuim").
- Selects the application plan to the "Requested plan" in the email. e.g. ("Unlimited") plan.
- When the application plan is selected, the greyed out "Change Plan" is highlighted.
- Clicks on "Change Plan".
- The application plan is changed (e.g. "Basic" to "Unlimited")
3scale sends an email notification to the developer that the application has been changed . The email is formatted using the "Application plan changed for buyer" email template.
Developer verifies the plan has been changed on the Developer Portal.
Root Cause
Changing a plan on the developer portal is not documented.
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