JAX-RS 2.0 support in JBoss EAP

Solution Verified - Updated -

Issue

  • When will RESTEasy 3.x be supported on JBoss EAP 6.x?
  • Can we use Jersey 2.7 in EAP 6.x?
  • what is the best and suitable way to upgrade to RestEasy 3?
  • Our Java Architects are asking me to upgrade our JBoss Domain EAP 4 to upgrade RestEasy from 2.x to 3.x. Here is a link. In this documentation, it seems that we will have to erase some file you provided, and I don't really like that mainly because we don't know what will happen in the next update of JBoss EAP and this could cause some trouble requesting more steps to complete any upgrade. What do you think about that ?
  • Can we replace a RESTEasy version shipped with the EAP 6.4 in llinux by the other resteasy-jaxrs-3.0.9.Final-all.zip? What about Redhat Support if we do it ?
  • A NoClassDefFoundError related to a JAX-RS 2.0 class. For example:
java.lang.NoClassDefFoundError: javax/ws/rs/container/ContainerResponseFilter

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP)
    • 7.x
    • 6.x
  • JAX-RS 2.0
  • RESTEasy 3.x
  • Jersey 2.7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In