Why CDI controller fails with Reconciler error "StorageClass.storage.k8s.io \"storage class name\" not found" ?

Solution In Progress - Updated -

Issue

  • During the upgrade, the kubevirt-hyperconverged-operator is stuck in Installing status.
 kubevirt-hyperconverged-operator.v4.9.2   OpenShift Virtualization      4.9.2     kubevirt-hyperconverged-operator.v4.9.1   Installing
  • The CDI is not available:
2022-02-21T11:14:53.036551357Z {"level":"info","ts":1645442093.0365405,"logger":"controller_hyperconverged","msg":"CDI is not 'Available'","Request.Namespace":"openshift-cnv","Request.Name":"kubevirt-hyperconverged"}
  • Below message is observed in the cdi-deployment pod continuosly:
{"level":"error","ts":1645589400.0923438,"logger":"controller-runtime.manager.controller.storageprofile-controller","msg":"Reconciler error","name":"ocs-external-storagecluster-cephfs","namespace":"","error":"StorageClass.storage.k8s.io \"ocs-external-storagecluster-cephfs\" not found"

Environment

  • OpenShift Virtualization 4.8.
  • OpenShift Virtualization 4.9.

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content