How do I update kubectl on Ansible Tower servers?

Solution Verified - Updated -

Issue

  • Security scan discovers an outdated version of kubectl installed

    The version of Kubernetes installed on the remote host is a version prior to 1.13.10, or 1.14.x prior to 1.14.6, or 1.15.x prior to 1.15.3. It is, therefore, affected by a denial of service vulnerability
    
    The remote host contains an application affected by a denial of service vulnerability.
    
    Remediation notes: Upgrade to Kubernetes 1.15.10, 1.16.7, 1.17.3 or later, please refer to the vendor advisory
    
    Path              : /bin/kubectl
    Installed version : 1.17.0
    Fixed version     : 1.17.3
    

Environment

  • Red Hat Enterprise Linux >= 7
  • Ansible Tower 3.8
  • Ansible Automation Platform 1.2

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content