Upgrade to Red Hat Ansible Tower 3.8.5 fails with an error `Error in PREIN scriptlet in rpm package ansible-tower-venv-ansible-3.8.5-2.el7at.x86_64` on RHEL7

Solution Verified - Updated -

Issue

  • Ansible Tower fails when trying to install ansible-tower-venv-ansible RPM package:
[...SNIP...]
TASK [packages_el : Install the Tower RPM.]                                                              
**********************************************************************************************************************************
fatal: [localhost]: FAILED! => {"changed": true, "changes": {"installed": ["ansible-tower = 3.8.5"], "updated": []}, "msg": "Error in PREIN scriptlet in  rpm package ansible-tower-venv-ansible-3.8.5-2.el7at.x86_64\nansible-tower-venv-ansible-3.8.4-1.el7at.x86_64 was  supposed to be removed  but is not!\n"
[...SNIP...]

Environment

  • Red Hat® Ansible Tower 3.8
  • Red Hat Enterprise Linux 7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content