Why do my HA-LVM volumes fail to stop cleanly when rgmanager starts on Red Hat Enterprise Linux 4?

Solution Unverified - Updated -

Issue

  • Why do my HA-LVM volumes fail to stop cleanly when rgmanager starts?

Environment

  • Red Hat 4 Cluster Suite
  • rgmanager service containing at least 1 HA-LVM resource and a filesystem resource mounted on it.Service is configured simlar to this below:
                    <resources>
                            <ip address="192.168.1.10" monitor_link="1"/>
                            <fs device="/dev/volgroup02/logvol02" force_fsck="0" force_unmount="1" fsid="42119" fstype="ext3" mountpoint="/home/filesystem1" name="filesystem1" options="" self_fence="0"/>
                            <fs device="/dev/volgroup03/logvol03" force_fsck="0" force_unmount="1" fsid="1585" fstype="ext3" mountpoint="/home/filesystem2" name="filesystem2" options="" self_fence="0"/>
                            <lvm lv_name="logvol02" name="volgroup02" vg_name="volgroup02"/>
                            <lvm lv_name="logvol03" name="volgroup03" vg_name="volgroup03"/>
                            <script file="/etc/cluster/ccb_cis" name="appserver"/>
                    </resources>
                    <service autostart="1" domain="domain1" name="service1">
                            <ip ref="192.168.1.10"/>
                            <fs ref="filesystem1"/>
                            <fs ref="filesystem2"/>
                            <lvm ref="volgroup02"/>
                            <lvm ref="volgroup03"/>
                            <script ref="appserver"/>
                    </service>
    

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content